summaryrefslogtreecommitdiff
path: root/libre/icedove/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2017-05-12 13:01:14 +0200
committerAndreas Grapentin <andreas@grapentin.org>2017-05-12 13:01:14 +0200
commit9fc967eeef3373585cac1d3ee0bf1ce26c70fe4f (patch)
tree5fd0cdae9abe2289ac3fc14dd256ebb3a24c3d00 /libre/icedove/PKGBUILD
parentcbeeb019ac26277420d29016e195ffbf66337b1b (diff)
downloadabslibre-9fc967eeef3373585cac1d3ee0bf1ce26c70fe4f.tar.gz
abslibre-9fc967eeef3373585cac1d3ee0bf1ce26c70fe4f.tar.bz2
abslibre-9fc967eeef3373585cac1d3ee0bf1ce26c70fe4f.zip
icedove: updated to 52.1 from upstream, dropped debian patches
Diffstat (limited to 'libre/icedove/PKGBUILD')
-rw-r--r--libre/icedove/PKGBUILD156
1 files changed, 75 insertions, 81 deletions
diff --git a/libre/icedove/PKGBUILD b/libre/icedove/PKGBUILD
index d037fa34f..09764810d 100644
--- a/libre/icedove/PKGBUILD
+++ b/libre/icedove/PKGBUILD
@@ -1,104 +1,101 @@
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Márcio Silva <coadde@parabola.nu>
+# Maintainer: Andreas Grapentin <andreas@grapentin.org>
+# Contributor: André Silva <emulatorman@riseup.net>
+# Contributor: Márcio Silva <coadde@riseup.net>
# Contributor: Luke R. <g4jc@openmailbox.org>
# Contributor: Isaac David <isacdaavid@isacdaavid.info>
-# We're getting this from Debian Sid
-_debname=icedove
-_brandingver=45.5.0
-_brandingrel=2
-_debver=45.8.0
-_debrel=deb3
-_debrepo=http://ftp.debian.org/debian/pool/main/
-_parabolarepo=https://repo.parabola.nu/other/icedove
-debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
-
-_pkgname=thunderbird
+_oldname=thunderbird
pkgname=icedove
+
epoch=1
-pkgver=$_debver.$_debrel
-pkgrel=2
+pkgver=52.1.0
+pkgrel=1
+_brandingver=52.1
+_brandingrel=1
-pkgdesc="A libre version of Debian Icedove, the standalone mail and news reader based on Mozilla Thunderbird."
arch=(i686 x86_64 armv7h)
+
+pkgdesc="Icedove, the libre standalone mail and news reader based on Mozilla Thunderbird."
+url="https://wiki.parabola.nu/$pkgname"
license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib gtk2 hunspell icu=59.1 libevent libvpx libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
+
+depends=(alsa-lib dbus-glib gtk2 gtk3 hunspell icu=59.1 libevent libvpx libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
makedepends=(autoconf2.13 diffutils gconf imake inetutils libpulse mesa mozilla-searchplugins pkg-config python2 quilt unzip yasm zip)
-options=(!emptydirs !makeflags)
+makedepends_i686=(cargo)
+makedepends_x86_64=("${makedepends_i686[@]}")
optdepends=('libcanberra: for sound support')
-url="https://wiki.parabola.nu/$pkgname"
-replaces=("$pkgname-libre" "$_pkgname")
-conflicts=("$pkgname-libre" "$_pkgname")
-provides=("$_pkgname")
+
+replaces=("$pkgname-libre" "$_oldname")
+conflicts=("$pkgname-libre" "$_oldname")
+provides=("$_oldname")
+
+options=(!emptydirs !makeflags)
+
install=$pkgname.install
-source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
- "$_debrepo/`debfile $_debname`_$_debver-${_debrel#deb}.debian.tar.xz"
+
+_parabolarepo=https://repo.parabola.nu/other/icedove
+
+source=("https://ftp.mozilla.org/pub/$_oldname/releases/$pkgver/source/$_oldname-$pkgver.source.tar.xz"
"$_parabolarepo/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz"
"$_parabolarepo/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz.sig"
mozconfig
$pkgname.desktop
changing-the-default-search-engine.patch
- firefox-gcc-6.0.patch mozilla-1228540.patch mozilla-1228540-1.patch
vendor.js
- fix-missing-files.patch
- no-neon.patch
- mozilla-1253216.patch)
-sha256sums=('49adb7d861bca2cddf20cd27533216e52a0a5a2431bd5663e931d8f60ee7e30f'
- 'cd14b9e991acbdf301aa172d7284cc2a8b5734ee478c74025bdbcd1df516da39'
- 'c3d021ee2af516fa694c65c54c4b239f4d5aa564590aefea665e20b1828e383d'
+ rust-fix-rusty-cheddar-crate-setup.patch
+ rust-target-i586-to-i686.patch
+ libre-searchengines.patch
+ no-neon.patch)
+sha256sums=('c33ca35b6acd1a0dc0d0f4b1df16745a33144c5d3d3715fe05454a5e9eefd48b'
+ '246418976524fbead5b99e6227f97322f8d4c45e0edf9ce75561ae8eccdefc65'
'SKIP'
- '7d8e38540e70502fc80d0301056414bdb9484aeb6ab65a11bbc808ee5a8931f8'
+ '72c9edd6b901ec09b483f6c365d1f698ae91da85a21fa9fc167d475d13e35a4f'
'0b0d25067c64c6b829c84e5259ffca978e3971f85acc8483f47bdbed5b0b5b6a'
- 'e1f72c44e31f191271207fc874dcfbf3d504b6b42dc1bb063ba8c7c9ee032130'
- '4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf'
- '3a3e84c702ee31450a3e84698441aceb11cf44e64c9fedcaddb8cb50db759417'
- 'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19'
+ 'ff3474b7d8f7ad245a324c14f01daf05834462b4f0144fbc50f055ebb573dac8'
'058b58074368b57acf8a6df9a9ffac848b7d7b39f5abd84cb2039bcee42b73e2'
- '294a2cc7b0477ad285af10ac2a04b767cabec07f03b23da23014bda71caea510'
- '59f40d8b2480aa67bf76f4f119826b6828a6a59cc040caf1ab5a6e19eef44c6e'
- '1e7ef08acd46aeacc8cd8b2c89012983fb2c8c18648e0f3e9371b0c76caedbde')
+ 'e03cdc40e4ea39560aa230ef7a9c494f3a343c0feb8f43b68a47769f88f6b315'
+ '069fab4b99dd51d7d004124d0052ea7b864cf060ea943348d290ba6aae50b0ab'
+ '0db12bef46e0ad68dbdf6ce0c767956d6758b073531012a850e7975eda3fc7fe'
+ '59f40d8b2480aa67bf76f4f119826b6828a6a59cc040caf1ab5a6e19eef44c6e')
validpgpkeys=(
- 'C92BAA713B8D53D3CAE63FC9E6974752F9704456' # André Silva
- '684D54A189305A9CC95446D36B888913DDB59515' # Márcio Silva
+ 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
)
prepare() {
- cd "$srcdir/$_pkgname-$_debver"
- mv "$srcdir/debian" .
- rm -rv debian/logo
- rm -rv debian/patches/icedove{,-l10n} || true
- sed -i '\|icedove|d' debian/patches/series
- mv "$srcdir/$pkgname-$_brandingver/"{app-icons,icedove{-branding,.xpm},logo,preview.png} debian
- mv "$srcdir/$pkgname-$_brandingver/patches/"{icedove,iceowl} debian/patches
- mv "$srcdir/$pkgname-$_brandingver/patches/debian-hacks/Icedove-branding.patch" debian/patches/debian-hacks
- cat "$srcdir/$pkgname-$_brandingver/patches/series" >> debian/patches/series
-
- export QUILT_PATCHES=debian/patches
- export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
- export QUILT_DIFF_ARGS='--no-timestamps'
+ cd "$srcdir/$_oldname-$pkgver"
+
+ local brandingdir="$srcdir/$pkgname-$_brandingver"
# Prepare branding for the Icedove packages
mkdir -v mail/branding/$pkgname
- # Copy needed icons
- cp -va debian/$pkgname-branding/* mail/branding/$pkgname
- for i in 16 22 24 32 48 256; do
- install -Dm644 debian/app-icons/$pkgname$i.png \
+ # copy the branding files
+ cp -va $brandingdir/$pkgname-branding/* mail/branding/$pkgname
+
+ # patch
+ export QUILT_PATCHES=$brandingdir/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
+
+ quilt push -av
+
+ # install the icons
+ for i in 16 22 24 32 48 64 128 256; do
+ install -Dm644 $brandingdir/app-icons/$pkgname$i.png \
mail/branding/$pkgname/mailicon$i.png
done
for i in 48 64; do
- install -Dm644 debian/app-icons/$pkgname$i.png \
+ install -Dm644 $brandingdir/app-icons/$pkgname$i.png \
mail/branding/$pkgname/content/icon$i.png
done
- cp -av debian/preview.png mail/themes/linux/mail/preview.png
+ cp -av $brandingdir/preview.png mail/themes/linux/mail/preview.png
- # Useless since we are doing it ourselves
- rm -v debian/patches/debian-hacks/changing-the-default-search-engine.patch || true
-
- quilt push -av
+ # Fix rust build
+ patch -Np1 -i "$srcdir/rust-fix-rusty-cheddar-crate-setup.patch"
+ patch -Np1 -i "$srcdir/rust-target-i586-to-i686.patch"
- # Fix missing files
- patch -Np1 -i "$srcdir/fix-missing-files.patch"
+ # Fix freedom issues
+ patch -Np1 -i "$srcdir/libre-searchengines.patch"
# Remove url-classifier from package-manifest.in to build and disable Phishing Protection
sed -i '\|Phishing Protection|d
@@ -114,13 +111,9 @@ prepare() {
\|extensions[.]webservice[.]discoverURL| s|https://services[.]addons[.]mozilla[.]org.\+["][)][;]|https://directory.fsf.org/wiki/Icedove");|g;
' mail/app/profile/all-thunderbird.js
- # Required for GCC 6
- patch -d mozilla -Np1 < ../firefox-gcc-6.0.patch
- patch -d mozilla -Np1 < ../mozilla-1228540.patch
- patch -d mozilla -Np1 < ../mozilla-1228540-1.patch
-
cp -v "$srcdir/mozconfig" .mozconfig
+ # make sure we use python2
mkdir "$srcdir/path"
ln -s /usr/bin/python2 "$srcdir/path/python"
@@ -129,7 +122,7 @@ prepare() {
# Load our searchplugins
rm -rv mail/locales/en-US/searchplugins
- cp -av /usr/lib/mozilla/searchplugins mail/locales/en-US
+ cp -av /usr/lib/mozilla/searchplugins mail/locales/en-US/
# ARM-specific changes:
if [[ "$CARCH" == arm* ]]; then
@@ -137,7 +130,6 @@ prepare() {
sed -i 's/\^\[:space:\]\*/^[[:space:]]*/' mozilla/{,js/src/}configure
patch -Np0 -i ../no-neon.patch
- patch -p2 -d mozilla < ../mozilla-1253216.patch
sed -i '/ac_add_options --enable-gold/d' .mozconfig
cat >> .mozconfig <<- EOF
ac_add_options --disable-elf-hack
@@ -151,7 +143,7 @@ prepare() {
}
build() {
- cd "$srcdir/$_pkgname-$_debver"
+ cd "$srcdir/$_oldname-$pkgver"
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@@ -170,22 +162,24 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$_debver"
+ cd "$srcdir/$_oldname-$pkgver"
+
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
- install -Dm644 ../vendor.js "$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
+ install -Dm644 $srcdir/vendor.js "$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
+
+ local brandingdir="$srcdir/$pkgname-$_brandingver"
# Install Icedove menu icon
- install -Dm644 debian/$pkgname.xpm "$pkgdir/usr/share/pixmaps/$pkgname.xpm"
+ install -Dm644 $brandingdir/$pkgname.xpm "$pkgdir/usr/share/pixmaps/$pkgname.xpm"
# Install Icedove icons
- brandingdir=debian/app-icons
- icondir="$pkgdir/usr/share/icons/hicolor"
+ local icondir="$pkgdir/usr/share/icons/hicolor"
for i in 16 22 24 32 48 64 128 256; do
- install -Dm644 "$brandingdir/$pkgname$i.png" \
+ install -Dm644 "$brandingdir/app-icons/$pkgname$i.png" \
"$icondir/${i}x${i}/apps/$pkgname.png"
done
- install -Dm644 "$brandingdir/${pkgname}big.svg" \
+ install -Dm644 "$brandingdir/app-icons/${pkgname}big.svg" \
"$icondir/scalable/apps/$pkgname.svg"
# Install Icedove desktop