summaryrefslogtreecommitdiff
path: root/libre/icedove/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-04-11 09:47:43 +0200
committerAndreas Grapentin <andreas@grapentin.org>2019-04-11 09:47:43 +0200
commit55260b3ff3e09bb75d9924872c0ec0020ed29e2f (patch)
treefe90680f844b162273046090772d3e0458ed89a6 /libre/icedove/PKGBUILD
parent62b2f95814540ae1061c8f16250596d476149384 (diff)
downloadabslibre-55260b3ff3e09bb75d9924872c0ec0020ed29e2f.tar.gz
abslibre-55260b3ff3e09bb75d9924872c0ec0020ed29e2f.tar.bz2
abslibre-55260b3ff3e09bb75d9924872c0ec0020ed29e2f.zip
libre/icedove: updated to 60.6.1
Diffstat (limited to 'libre/icedove/PKGBUILD')
-rw-r--r--libre/icedove/PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/libre/icedove/PKGBUILD b/libre/icedove/PKGBUILD
index 61b925f5f..1c7ee1e96 100644
--- a/libre/icedove/PKGBUILD
+++ b/libre/icedove/PKGBUILD
@@ -20,7 +20,7 @@ _pkgname=thunderbird
pkgname=icedove
replaces=("$_pkgname")
epoch=1
-pkgver=60.5.1
+pkgver=60.6.1
pkgrel=2
pkgrel+=.parabola1
_brandingver=60.5
@@ -38,11 +38,13 @@ makedepends+=(quilt mozilla-searchplugins python2-blessings imagemagick)
optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
- $pkgname.desktop)
-source+=(https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig}
- mozilla-1238661.patch
- libre-searchengines.patch)
-sha256sums=('69a3f741b7378b50a3b6a3b59f6c4fedd2d82d469ab234390627e15da1b58e03'
+ rust-1.33.patch
+ $pkgname.desktop
+ https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig}
+ mozilla-1238661.patch
+ libre-searchengines.patch)
+sha256sums=('17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67'
+ '97bdb978d59cf5f0f967750e9d8dfbc8fc73367b08437838c44a308fe2ee5442'
'af8199a12ebe09189d143458bd1e2d0071aff3410ed121dc2329a448a56632f0'
'590862b39ba7baf60e47240e33de5839a8e85b6831c839ea57481968c9020241'
'SKIP'
@@ -53,6 +55,9 @@ validpgpkeys=(BFA8008A8265677063B11BF47171986E4B745536) # Andreas Grapentin
prepare() {
cd $_pkgname-$pkgver
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1539901 (Patch from Fedora)
+ patch -Np1 -i ../rust-1.33.patch
+
cat >.mozconfig <<END
ac_add_options --enable-application=comm/mail
ac_add_options --enable-calendar
@@ -62,7 +67,7 @@ ac_add_options --enable-release
ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
-ac_add_options --enable-rust-simd
+#ac_add_options --enable-rust-simd
# Branding
ac_add_options --disable-official-branding
@@ -102,6 +107,8 @@ END
cat >> .mozconfig <<END
ac_add_options --disable-webrtc
+ac_add_options --disable-elf-hack
+ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"
END
fi
@@ -155,12 +162,11 @@ build() {
cd $_pkgname-$pkgver
if [[ $CARCH = armv7h ]]; then
- export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
fi
if [[ $CARCH = i686 ]]; then
- export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
+ sed -i 's/\(cargo_rustc_flags += -C lto\)/#\1/' config/rules.mk
export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
fi