summaryrefslogtreecommitdiff
path: root/libre/icedove-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-04-15 06:02:00 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-04-15 06:02:00 -0300
commit6ccf0c035c6183dbd64e7a71db340762a3789c7a (patch)
tree8af1b2451745dd1c2928923d071edee3b43feb32 /libre/icedove-libre/PKGBUILD
parentfd04d9bbd17529b6acf413a14b805066c03c5d38 (diff)
downloadabslibre-6ccf0c035c6183dbd64e7a71db340762a3789c7a.tar.gz
abslibre-6ccf0c035c6183dbd64e7a71db340762a3789c7a.tar.bz2
abslibre-6ccf0c035c6183dbd64e7a71db340762a3789c7a.zip
icedove-libre-17.0.5.1-1: updating version
Diffstat (limited to 'libre/icedove-libre/PKGBUILD')
-rw-r--r--libre/icedove-libre/PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/libre/icedove-libre/PKGBUILD b/libre/icedove-libre/PKGBUILD
index a6825ea97..43212c413 100644
--- a/libre/icedove-libre/PKGBUILD
+++ b/libre/icedove-libre/PKGBUILD
@@ -3,7 +3,7 @@
# We're getting this from Debian Experimental
_debname=icedove
-_debver=17.0.4
+_debver=17.0.5
_debrel=1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -11,7 +11,7 @@ debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=${_debname}
pkgname=${_debname}-libre
pkgver=${_debver}.${_debrel}
-pkgrel=3
+pkgrel=1
pkgdesc="A libre version of Debian Icedove, the standalone mail/news reader based on Mozilla Thunderbird."
arch=('i686' 'x86_64' 'mips64el')
license=('MPL' 'GPL' 'LGPL')
@@ -26,17 +26,17 @@ install=${_pkgname}.install
source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
"${_debrepo}/`debfile ${_debname}`_${_debver}-${_debrel}.debian.tar.gz"
mozconfig
- channel-prefs.js
+ replace-urls.txt
vendor.js
makefile.patch
branding.patch
${_pkgname}.desktop
Icedove-branding.patch)
options=(!emptydirs)
-md5sums=('26ce85189f3b55cc2c97c57e18c1e2de'
- 'fafa558c1940a48c3f29de61dc27d737'
+md5sums=('0c68298c17757257da79b6bb39e3fd10'
+ 'eb2a5e1877d87a16e10388f533c081a6'
'5cf95ea94f69cdd36604890cfbf7b954'
- '476ec205162340fb0679f522c9d31c3b'
+ 'a8fc4658d45b6bf9350023e5c3f34e56'
'4eecc4fc5aafaf0da651a09eadc90bee'
'c4ed43e85945e180a89cce03e45ec62c'
'126b1446212396c33220936c01d9592d'
@@ -72,6 +72,17 @@ prepare() {
patch -Np1 -i "${srcdir}/branding.patch" # fixing branding
patch -Np1 -i "${srcdir}/Icedove-branding.patch" # debian patch fixed version
+ # Replace common URLs
+ sed '/^#/d' ../replace-urls.txt | while read -r moz_url gnu_url; do
+ if [[ -n $moz_url ]]; then
+ printf 'liberating: %s -> %s\n' "$moz_url" "$gnu_url"
+ grep -Erl "${moz_url}" \
+ --exclude='*.'{patch,orig,rej} \
+ --exclude-dir={.pc,test,tests,testing} \
+ | xargs -d '\n' --no-run-if-empty sed -ri "s<${moz_url}<${gnu_url}<g"
+ fi
+ done
+
cp "${srcdir}/mozconfig" .mozconfig
# configure script misdetects the preprocessor without an optimization level
@@ -82,7 +93,7 @@ prepare() {
build() {
cd "${srcdir}/${DEBIAN_BUILD}"
- export LDFLAGS="${LDFLAGS} -Wl,--as-needed,-rpath,/usr/lib/${_pkgname}"
+ export LDFLAGS="${LDFLAGS} -Wl,-rpath,/usr/lib/${_pkgname}"
export PYTHON="/usr/bin/python2"
make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}"
@@ -110,6 +121,7 @@ package() {
ln -sf /usr/share/hunspell "${pkgdir}/usr/lib/${_pkgname}/dictionaries"
ln -sf /usr/share/hyphen "${pkgdir}/usr/lib/${_pkgname}/hyphenation"
ln -sf /usr/lib/mozilla/searchplugins "${pkgdir}/usr/lib/${_pkgname}/searchplugins"
+
# We don't want the development stuff
rm -r "${pkgdir}"/usr/{include,lib/$_pkgname-devel,share/idl}
}