summaryrefslogtreecommitdiff
path: root/libre/gstreamer0.10-bad-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-05 14:49:47 -0300
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-05 14:49:47 -0300
commitbc8cf47612516f8680ddd3a48b17288deaeebdf0 (patch)
tree54c452dd60de16a51813585107aeacf1c8d211c3 /libre/gstreamer0.10-bad-libre/PKGBUILD
parent421402c1b6f8cd3de57405c3025e44561c290c79 (diff)
downloadabslibre-bc8cf47612516f8680ddd3a48b17288deaeebdf0.tar.gz
abslibre-bc8cf47612516f8680ddd3a48b17288deaeebdf0.tar.bz2
abslibre-bc8cf47612516f8680ddd3a48b17288deaeebdf0.zip
gstreamer0.10-bad-libre-0.10.23-2: updating version and adding wildmidi dependency
Diffstat (limited to 'libre/gstreamer0.10-bad-libre/PKGBUILD')
-rw-r--r--libre/gstreamer0.10-bad-libre/PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/libre/gstreamer0.10-bad-libre/PKGBUILD b/libre/gstreamer0.10-bad-libre/PKGBUILD
index c27cf61f9..b74958e3c 100644
--- a/libre/gstreamer0.10-bad-libre/PKGBUILD
+++ b/libre/gstreamer0.10-bad-libre/PKGBUILD
@@ -1,15 +1,15 @@
-# $Id: PKGBUILD 153262 2012-03-12 17:29:57Z jgc $
+# $Id: PKGBUILD 160766 2012-06-05 08:51:20Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Maintainer (Parabola): fauno <fauno@kiwwwi.com.ar>
-# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+# Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
pkgbase=gstreamer0.10-bad-libre
pkgname=('gstreamer0.10-bad-libre' 'gstreamer0.10-bad-libre-plugins')
pkgver=0.10.23
-pkgrel=1.2
+pkgrel=2
arch=('i686' 'x86_64')
license=('LGPL' 'GPL')
-makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg')
+makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi')
url="http://gstreamer.freedesktop.org/"
options=(!libtool !emptydirs)
source=(${url}/src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz)
@@ -26,10 +26,15 @@ build() {
sed -e 's/gst sys ext/gst/' -i Makefile
}
+# Disable for now: 2 tests fail, one of them is because of not having a camera during build.
+#check() {
+# cd "${srcdir}/gst-plugins-bad-${pkgver}"
+# make check
+#}
+
package_gstreamer0.10-bad-libre() {
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad)"
depends=('gstreamer0.10-base>=0.10.34')
- groups=('gstreamer0.10-plugins')
provides=("gstreamer0.10-bad=$pkgver")
conflicts=('gstreamer0.10-bad')
replaces=('gstreamer0.10-bad')
@@ -40,7 +45,7 @@ package_gstreamer0.10-bad-libre() {
package_gstreamer0.10-bad-libre-plugins() {
pkgdesc="GStreamer Multimedia Framework Bad Plugins (gst-plugins-bad)"
- depends=("gstreamer0.10-bad-libre=${pkgver}" 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'libvdpau' 'soundtouch' 'libass' 'schroedinger' 'libvpx' 'gsm' 'rtmpdump' 'libgme' 'libsndfile' 'librsvg')
+ depends=("gstreamer0.10-bad-libre=${pkgver}" 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'libvdpau' 'soundtouch' 'libass' 'schroedinger' 'libvpx' 'gsm' 'rtmpdump' 'libgme' 'libsndfile' 'librsvg' 'wildmidi')
groups=('gstreamer0.10-plugins')
install=gstreamer0.10-bad-plugins.install
provides=("gstreamer0.10-bad-plugins=$pkgver")