summaryrefslogtreecommitdiff
path: root/libre/gsoap-legacy/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@parabola.nu>2013-07-03 10:33:32 -0300
committerNicolás Reynolds <fauno@parabola.nu>2013-07-03 10:33:32 -0300
commit8647aee53c2f9f5458e57fe7ac212da40a555594 (patch)
treeb99a8fbc859d18a244ea5ac496083e66ffaa330d /libre/gsoap-legacy/PKGBUILD
parent3a14409a347f3423bf2a4ab847edff625b671e20 (diff)
parent0a5c7083d197551290bc762f4ba90210cb733a5e (diff)
downloadabslibre-8647aee53c2f9f5458e57fe7ac212da40a555594.tar.gz
abslibre-8647aee53c2f9f5458e57fe7ac212da40a555594.tar.bz2
abslibre-8647aee53c2f9f5458e57fe7ac212da40a555594.zip
Merge branch 'master' of vparabola:abslibre
Conflicts: java/not-working/java-bnd/PKGBUILD libre/parabola-keyring/PKGBUILD
Diffstat (limited to 'libre/gsoap-legacy/PKGBUILD')
-rw-r--r--libre/gsoap-legacy/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/libre/gsoap-legacy/PKGBUILD b/libre/gsoap-legacy/PKGBUILD
new file mode 100644
index 000000000..addcd690a
--- /dev/null
+++ b/libre/gsoap-legacy/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Tor Krill <tor@krill.nu>
+# Contributor: Lee.MaRS <leemars@gmail.com>
+
+_pkgname=gsoap
+pkgname=gsoap-legacy
+pkgver=2.8.11
+pkgrel=1
+pkgdesc="Offers an XML language binding to ease the development of SOAP/XML Web services in C and C/C++ (legacy version)"
+url="http://www.cs.fsu.edu/~engelen/soap.html"
+arch=('i686' 'x86_64')
+license=('GPL' 'custom')
+depends=('openssl' 'zlib' 'gcc-libs')
+makedepends=('autoconf' 'automake')
+conflicts=('gsoap')
+source=(http://prdownloads.sourceforge.net/gsoap2/${_pkgname}_${pkgver}.zip
+ LICENSE)
+md5sums=('ea2d7ee876d274a188b8fbb365702eec'
+ '27aaa3f5166db94d44044c11a7b2c37b')
+
+build() {
+ cd $srcdir/gsoap-2.8
+ [ -f Makefile ] || CXXFLAGS=-fPIC CFLAGS=-fPIC LDFLAGS=-fPIC ./configure --prefix=/usr
+ make -j1
+}
+
+package() {
+ cd $srcdir/gsoap-2.8
+ make DESTDIR=$pkgdir install
+ mkdir -p $pkgdir/usr/share/gsoap/import
+ mkdir -p $pkgdir/usr/share/gsoap/WS
+ cp -R gsoap/import $pkgdir/usr/share/gsoap/
+ cp -R gsoap/WS $pkgdir/usr/share/gsoap/
+ install -D ../LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+}