summaryrefslogtreecommitdiff
path: root/libre/ghostscript-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-17 21:07:08 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-17 21:07:08 -0200
commitbebd25d7a8d96183692bcf3cef921e93befa49ac (patch)
tree6f7721ff37f426b5dbd80f2811da0a37cfef82c0 /libre/ghostscript-libre/PKGBUILD
parentb049eaafa7881fb4138bb50ed1109bf55462008d (diff)
downloadabslibre-bebd25d7a8d96183692bcf3cef921e93befa49ac.tar.gz
abslibre-bebd25d7a8d96183692bcf3cef921e93befa49ac.tar.bz2
abslibre-bebd25d7a8d96183692bcf3cef921e93befa49ac.zip
ghostscript-libre-9.07-1: updating version
* Change license * Remove unnecessaries patches
Diffstat (limited to 'libre/ghostscript-libre/PKGBUILD')
-rw-r--r--libre/ghostscript-libre/PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/libre/ghostscript-libre/PKGBUILD b/libre/ghostscript-libre/PKGBUILD
index 499f4bab0..cf00963b8 100644
--- a/libre/ghostscript-libre/PKGBUILD
+++ b/libre/ghostscript-libre/PKGBUILD
@@ -1,16 +1,17 @@
-# $Id: PKGBUILD 165015 2012-08-08 19:40:10Z andyrtr $
+# $Id: PKGBUILD 178158 2013-02-17 10:57:03Z andyrtr $
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Maintainer (Parabola): Joshua Haase <hahj87@gmail.com>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
_pkgname=ghostscript
pkgname=ghostscript-libre
-pkgver=9.06
-pkgrel=1.1 # rebuild for mips64el -march
+pkgver=9.07
+pkgrel=1 # rebuild for mips64el -march
pkgdesc="An interpreter for the PostScript language without non-free files"
arch=('i686' 'x86_64' 'mips64el')
-license=('GPL3') #non free files removed
-depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
+license=('AGPL') #non free files removed
+depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
+ 'libtiff>=4.0.0' 'lcms' 'dbus')
makedepends=('gtk2' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
'gtk2: needed for gsx')
@@ -18,17 +19,12 @@ conflicts=('ghostscript')
replaces=('ghostscript')
provides=("ghostscript=$pkgver")
url="http://www.ghostscript.com/"
-source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
- ijs-automake.patch)
+source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
options=('!libtool')
-md5sums=('46f9ebe40dc52755287b30704270db11'
- '686830841eb9004143a0d0f56b73aaaf')
+md5sums=('eea27befc1e85bef6d4768202f6b03a5')
build() {
cd ${srcdir}/ghostscript-${pkgver}
-
- # Fix build with recent automake.
- patch -p1 -i "$srcdir/ijs-automake.patch"
# delete non-free packages
grep -l "are not altered" Resource/CMap/* | xargs rm -fv
@@ -49,12 +45,14 @@ build() {
--enable-fontconfig \
--enable-freetype \
--without-luratech \
+ --without-omni \
--with-system-libtiff \
--disable-compile-inits #--help # needed for linking with system-zlib
make
# Build IJS
cd ${srcdir}/ghostscript-${pkgver}/ijs
+ sed -i "s:AM_PROG_CC_STDC:AC_PROG_CC:g" configure.ac
./autogen.sh
./configure --prefix=/usr --enable-shared --disable-static
make