summaryrefslogtreecommitdiff
path: root/libre/ghostscript-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-05-25 13:00:13 -0300
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-05-25 13:00:13 -0300
commitbeaac191069711d88a4262d5fa6d541ea006e957 (patch)
tree6ad4cf085bcb7d2f20bb5a92ce77c8ce5610c19d /libre/ghostscript-libre/PKGBUILD
parentd6fedc876625ef84d79ee65e460f0df0e082af95 (diff)
downloadabslibre-beaac191069711d88a4262d5fa6d541ea006e957.tar.gz
abslibre-beaac191069711d88a4262d5fa6d541ea006e957.tar.bz2
abslibre-beaac191069711d88a4262d5fa6d541ea006e957.zip
ghostscript-libre-9.05-1: updating version
Diffstat (limited to 'libre/ghostscript-libre/PKGBUILD')
-rw-r--r--libre/ghostscript-libre/PKGBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/libre/ghostscript-libre/PKGBUILD b/libre/ghostscript-libre/PKGBUILD
index 4462b7792..e857eacf6 100644
--- a/libre/ghostscript-libre/PKGBUILD
+++ b/libre/ghostscript-libre/PKGBUILD
@@ -1,14 +1,15 @@
-# $Id: PKGBUILD 146976 2012-01-19 20:56:52Z andyrtr $
+# $Id: PKGBUILD 149732 2012-02-09 20:34:33Z andyrtr $
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Maintainer (Parabola): xihh
+# Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
+_pkgname=ghostscript
pkgname=ghostscript-libre
-pkgver=9.04
-_srcpkgrel=5
-pkgrel=6
+pkgver=9.05
+pkgrel=1
pkgdesc="An interpreter for the PostScript language without non-free files"
-arch=('i686' 'x86_64')
-license=('GPL3') #non free files removed
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL3' 'custom') #non free files removed
depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
makedepends=('gtk2' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
@@ -17,22 +18,15 @@ conflicts=('ghostscript')
replaces=('ghostscript-lrpng' 'ghostscript')
provides=('ghostscript-lprng' "ghostscript=$pkgver")
url="http://www.ghostscript.com/"
-source=(https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-${_srcpkgrel}-any.src.tar.xz
- ghostscript-cups-rgbw.patch
- ghostscript-gpl-9.04-freetype-underlinking.patch)
+source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
options=('!libtool' '!makeflags')
-md5sums=('ac8f77c94a6b5d5f0170c2e6db38c6bb'
- 'bc56eb8c5fef0ecf964f6b3e9b7e65ae'
- 'a1928c3e4459dcfee0aaa4b38fadba57')
+md5sums=('8bcef1f33ddf8a4d12b2cf8da385c191')
build() {
cd ${srcdir}/ghostscript-${pkgver}
- # fix broken color printing https://bugs.archlinux.org/task/25519
- patch -Np1 -i ${srcdir}/ghostscript-cups-rgbw.patch
-
- # fix a linking issue
- patch -Np1 -i ${srcdir}/ghostscript-gpl-9.04-freetype-underlinking.patch
+ # delete non-free packages
+ grep -l "are not altered" Resource/CMap/* | xargs rm -fv
# force it to use system-libs
rm -rf jpeg libpng zlib jasper expat tiff lcms freetype
@@ -49,6 +43,7 @@ build() {
--enable-fontconfig \
--enable-freetype \
--without-luratech \
+ --with-system-libtiff \
--disable-compile-inits #--help # needed for linking with system-zlib
make
@@ -68,8 +63,8 @@ package() {
# install missing doc files # http://bugs.archlinux.org/task/18023
install -m 644 ${srcdir}/ghostscript-${pkgver}/doc/{Ps2ps2.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} ${pkgdir}/usr/share/ghostscript/$pkgver/doc/
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- install -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+ mkdir -p ${pkgdir}/usr/share/licenses/${_pkgname}
+ install -m644 LICENSE ${pkgdir}/usr/share/licenses/${_pkgname}/
# remove unwanted localized man-pages
rm -rf $pkgdir/usr/share/man/[^man1]*