summaryrefslogtreecommitdiff
path: root/libre/ghostscript-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-11-10 15:40:13 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-11-10 15:40:13 -0300
commit670af4204ef3b1963ef9529cd420dfeb4d66cd84 (patch)
treef8c093cf4040e38a91395ef841572fcf3ac53ed8 /libre/ghostscript-libre/PKGBUILD
parent8c6397096a684881fb3e15f3685f06861d0b685d (diff)
downloadabslibre-670af4204ef3b1963ef9529cd420dfeb4d66cd84.tar.gz
abslibre-670af4204ef3b1963ef9529cd420dfeb4d66cd84.tar.bz2
abslibre-670af4204ef3b1963ef9529cd420dfeb4d66cd84.zip
libre/ghostscript-libre-9.04-5
Diffstat (limited to 'libre/ghostscript-libre/PKGBUILD')
-rw-r--r--libre/ghostscript-libre/PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/libre/ghostscript-libre/PKGBUILD b/libre/ghostscript-libre/PKGBUILD
index fb41750cf..eda488048 100644
--- a/libre/ghostscript-libre/PKGBUILD
+++ b/libre/ghostscript-libre/PKGBUILD
@@ -3,12 +3,12 @@
# Maintainer (Parabola): xihh
pkgname=ghostscript-libre
-pkgver=9.02
-pkgrel=2
+pkgver=9.04
+pkgrel=5
pkgdesc="An interpreter for the PostScript language without non-free files"
arch=('i686' 'x86_64')
license=('GPL3') #non free files removed
-depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng' 'libjpeg' 'libtiff')
+depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng' 'libjpeg' 'libtiff' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
makedepends=('gtk2' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
'gtk2: needed for gsx')
@@ -16,17 +16,18 @@ conflicts=('ghostscript')
replaces=('ghostscript-lrpng' 'ghostscript')
provides=('ghostscript-lprng' "ghostscript=$pkgver")
url="http://www.ghostscript.com/"
-source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
+source=(https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-${pkgrel}-any.src.tar.xz
+ ghostscript-cups-rgbw.patch)
options=('!libtool' '!makeflags')
-md5sums=('f67151444bd56a7904579fc75a083dd6')
build() {
cd ${srcdir}/ghostscript-${pkgver}
+
+ # fix broken color printing https://bugs.archlinux.org/task/25519
+ patch -Np1 -i ${srcdir}/ghostscript-cups-rgbw.patch
# force it to use system-libs
- rm -rf jpeg libpng zlib jasper expat tiff
- # delete non-free packages
- grep -l "are not altered" Resource/CMap/* | xargs rm -fv
+ rm -rf jpeg libpng zlib jasper expat tiff freetype lcms
./configure --prefix=/usr \
--enable-dynamic \
@@ -36,7 +37,11 @@ build() {
--with-x \
--with-drivers=ALL\
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
- --disable-compile-inits # needed for linking with system-zlib
+ --with-install-cups \
+ --enable-fontconfig \
+ --enable-freetype \
+ --without-luratech \
+ --disable-compile-inits #--help # needed for linking with system-zlib
make
# Build IJS
@@ -65,3 +70,5 @@ package() {
cd ${srcdir}/ghostscript-${pkgver}/ijs
make DESTDIR=${pkgdir} install
}
+md5sums=('ac8f77c94a6b5d5f0170c2e6db38c6bb'
+ 'fd89baafac6589dc93ba71a48c2ba9b4')