summaryrefslogtreecommitdiff
path: root/libre/epiphany/PKGBUILD
diff options
context:
space:
mode:
authorIsaac David <isacdaavid@isacdaavid.info>2017-10-15 10:15:04 -0500
committerIsaac David <isacdaavid@isacdaavid.info>2017-10-15 10:15:04 -0500
commit9071b3c79de04c579d426b0970669ec2c14ab1c7 (patch)
tree0860fd9ed215cacd4462061e2a28d9770d2d45b5 /libre/epiphany/PKGBUILD
parent1f886ae4ec34af85b66b85ab92254196ec45cd65 (diff)
downloadabslibre-9071b3c79de04c579d426b0970669ec2c14ab1c7.tar.gz
abslibre-9071b3c79de04c579d426b0970669ec2c14ab1c7.tar.bz2
abslibre-9071b3c79de04c579d426b0970669ec2c14ab1c7.zip
epiphany: update to 3.26.1
Diffstat (limited to 'libre/epiphany/PKGBUILD')
-rw-r--r--libre/epiphany/PKGBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/libre/epiphany/PKGBUILD b/libre/epiphany/PKGBUILD
index 5205706cc..88aa79a53 100644
--- a/libre/epiphany/PKGBUILD
+++ b/libre/epiphany/PKGBUILD
@@ -3,31 +3,32 @@
# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
pkgname=epiphany
-pkgver=3.24.3
+pkgver=3.26.1
pkgrel=1.parabola1
pkgdesc="A GNOME web browser based on the WebKit rendering engine, with DuckDuckGo HTML support"
url="https://wiki.gnome.org/Apps/Web"
arch=(i686 x86_64 armv7h)
license=(GPL)
depends=(webkit2gtk gcr gnome-desktop icu)
-makedepends=(intltool itstool docbook-xml startup-notification lsb-release
- gobject-introspection yelp-tools autoconf-archive appstream-glib git)
+makedepends=(itstool docbook-xml startup-notification lsb-release
+ gobject-introspection yelp-tools appstream-glib git meson)
groups=(gnome)
replaces=(${pkgname}-libre)
conflicts=(${pkgname}-libre)
-_commit=43489a7d54b89a45709fadd6a90d0e99cf0dc45d # tags/3.24.3^0
+_commit=70755404799e4393bf5605c9debec6877acf0177 # tags/3.26.1
source=("git+https://git.gnome.org/browse/epiphany#commit=$_commit"
"git+https://git.gnome.org/browse/libgd"
"git+https://git.gnome.org/browse/gvdb"
pluginsdir.diff
- privacy.patch)
+ libre.patch)
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '3bbd4b36e697a3a9165e0b71d5af566fe96a8f1237d854b9dee9a7e0b9fef8e3'
- '4cfef33af39c2292f5a5378154adb94be5937dc065b881b168b5df99557474f1')
+ '0e4db79fe22a4ed447aa926eecd09fc660cf2f5aac2d42aa9adaacad45416faf'
+ '8cee8e5f896ce12832d50e7ab97ef16165d70d135018742e0f5bc15507d4e708')
pkgver() {
cd $pkgname
@@ -35,30 +36,25 @@ pkgver() {
}
prepare() {
+ mkdir build
cd $pkgname
patch -Np1 -i ../pluginsdir.diff
- patch -Np1 -i ../privacy.patch
+ patch -Np1 -i ../libre.patch
git submodule init
git config --local submodule.libgd.url "$srcdir/libgd"
git config --local submodule.gvdb.url "$srcdir/gvdb"
git submodule update
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $pkgname
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib/$pkgname --enable-compile-warnings=yes
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ cd build
+ arch-meson ../$pkgname -Ddistributor_name="Parabola GNU/Linux-libre"
+ ninja
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ cd build
+ DESTDIR="$pkgdir" ninja install
}