summaryrefslogtreecommitdiff
path: root/libre/doublecmd/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-15 16:58:15 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-15 16:58:29 +0100
commit3578b4bbe7aa020565cf76bf44650ba291124413 (patch)
treee2bcc1f42801a767be2a68bcbae4efa398a849d8 /libre/doublecmd/PKGBUILD
parentf74b15f3dc060933aa460657641b69c5c51c6e46 (diff)
downloadabslibre-3578b4bbe7aa020565cf76bf44650ba291124413.tar.gz
abslibre-3578b4bbe7aa020565cf76bf44650ba291124413.tar.bz2
abslibre-3578b4bbe7aa020565cf76bf44650ba291124413.zip
libre/doublecmd: updated to 0.8.1
Diffstat (limited to 'libre/doublecmd/PKGBUILD')
-rw-r--r--libre/doublecmd/PKGBUILD150
1 files changed, 74 insertions, 76 deletions
diff --git a/libre/doublecmd/PKGBUILD b/libre/doublecmd/PKGBUILD
index 0b5595c07..436bb2821 100644
--- a/libre/doublecmd/PKGBUILD
+++ b/libre/doublecmd/PKGBUILD
@@ -1,113 +1,111 @@
# vim:set ft=sh:
-# $Id: PKGBUILD 214257 2017-02-28 19:42:14Z idevolder $
+# $Id$
# Maintainer (Arch): BlackIkeEagle <ike DOT devolder AT gmail DOT com>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor (Arch): (sirocco AT ngs.ru)
-# Maintainer: André Silva <emulatorman@hyperbola.info>
pkgbase=doublecmd
-_pkgbase=$pkgbase-libre
-pkgname=("$pkgbase-gtk2" "$pkgbase-qt")
-pkgver=0.7.8
+pkgname=('doublecmd-gtk2' 'doublecmd-qt4' 'doublecmd-qt5')
+pkgver=0.8.1
_helpver=0.6.0
pkgrel=1.parabola1
-url="http://$pkgbase.sourceforge.net/"
-arch=('i686' 'x86_64')
+url="http://doublecmd.sourceforge.net/"
+arch=('x86_64' 'i686' 'armv7h')
license=('GPL')
provides=("$pkgbase")
-makedepends=('lazarus' 'qt4pas' 'gtk2')
+makedepends=('lazarus' 'qt4pas' 'qt5pas' 'gtk2')
optdepends=(
'lua51: scripting'
'p7zip: support for 7zip archives'
)
-mksource=(
- "http://downloads.sourceforge.net/project/$pkgbase/Double%20Commander%20Source/$pkgbase-$pkgver-src.tar.gz"
-)
source=(
- "https://repo.parabola.nu/other/$_pkgbase/$_pkgbase-$pkgver-src.tar.gz"
- "http://downloads.sourceforge.net/project/$pkgbase/Double%20Commander%20Source/$pkgbase-help-$_helpver-src.tar.gz"
- "http://www.herecura.be/files/lazarus-20140321-2.tar.gz"
- 'libre.patch'
- 'help-libre.patch'
+ "https://downloads.sourceforge.net/project/$pkgbase/Double%20Commander%20Source/$pkgbase-$pkgver-src.tar.gz"
+ "https://downloads.sourceforge.net/project/$pkgbase/Double%20Commander%20Source/$pkgbase-help-$_helpver-src.tar.gz"
+ "libre.patch"
+ "help-libre.patch"
)
-mksha256sums=('5249557df3715588f379292258b937e37a097bf584602711bc211dfd6427e9a3')
-sha256sums=('f66142f12efa5738bf8296e72d93db7e6adadb4920b9e14b2d849f5878a11efd'
- 'd50a58f0e8c25c07720f2afd987213f330dfce268e2aef349d1da3de2eef1c39'
- '16560ad7403ffbee1800384768828e1fad924d03068c6248b68a78c393fc4e20'
- 'a23303f1719be08a59038ce7a256d582868cdd3e19cda2537c4a23d3480a40f9'
- '62bc9fd628ca8dc11446f2f3b44ebf86bbf1776a7e8def11fbeb77589e9a5a6e')
+sha512sums=('8e80ba5914362572d77403e054873665dcf9dcf2dd9258acd07888aa5dfa05e7b6537e9e7750f26eadb09091915bd314f859d29c0527bb3aa45e936763a664d4'
+ '2fe7a58e317c93baf4cfcb9cfc660647d71f4454eef588a512a9b9e8467477a691ec1061f014a42dff4ae0a0ba0600824b33c12c950fe1e26fba2a51122404bb'
+ '874a81b27d891cff3eefc8ed6aa128b4eb4abeb4e69247108544a60cda9a3f98b552196a8414d4835d358a426d74ff10823610acf605d3a4d5651f6c9dd3dcfa'
+ 'f71a328d592c4f45535480477e3e6a2e0dc3ea08bfae059a3f707a2d7d8d85407379dfbe8c54fb179e4f10c4d5078f29063ccd763d1af6525152053b6f00f746')
mksource() {
- cd "$pkgbase-$pkgver"
+ cd "$pkgbase-$pkgver"
- msg2 'remove nonfree unRAR utility files from the source'
- rm -rv install/linux/deb/libunrar
+ msg2 'remove nonfree unRAR utility files from the source'
+ rm -rv install/linux/deb/libunrar
}
prepare() {
- cd "$pkgbase-$pkgver"
- sed -e 's/LIB_SUFFIX=.*/LIB_SUFFIX=/g' -i install/linux/install.sh
+ cd "$pkgbase-$pkgver"
+ sed -e 's/LIB_SUFFIX=.*/LIB_SUFFIX=/g' -i install/linux/install.sh
+ sed -e 's/=$(which lazbuild)/="$(which lazbuild) --lazarusdir=\/usr\/lib\/lazarus"/' -i build.sh
- msg2 'remove nonfree libunrar, unace, unarj support and references'
- rm -rv plugins/wcx/unrar
- rm -v install/linux/rpm/libunrar.spec
- rm -v install/darwin/make-unrar.sh
- patch -Np1 -i ../libre.patch
+ msg2 'remove nonfree libunrar, unace, unarj support and references'
+ rm -rv plugins/wcx/unrar
+ rm -v install/linux/rpm/libunrar.spec
+ rm -v install/darwin/make-unrar.sh
+ patch -Np1 -i "$srcdir"/libre.patch
- cd "$srcdir/$pkgbase-help-$_helpver"
+ cd "$srcdir/$pkgbase-help-$_helpver"
- msg2 'remove nonfree libunrar, unace, unarj support and references on the help'
- patch -Np1 -i ../help-libre.patch
+ msg2 'remove nonfree libunrar, unace, unarj support and references on the help'
+ patch -Np1 -i "$srcdir"/help-libre.patch
- cd "$srcdir"
+ cd "$srcdir"
- cp -a "$pkgbase-$pkgver" "$pkgbase-gtk"
- cp -a "$pkgbase-$pkgver" "$pkgbase-qt"
+ cp -a "$pkgbase-$pkgver" "$pkgbase-gtk"
+ cp -a "$pkgbase-$pkgver" "$pkgbase-qt4"
+ cp -a "$pkgbase-$pkgver" "$pkgbase-qt5"
}
build() {
- msg2 'build gtk'
- gtkdir="$srcdir/$pkgbase-gtk"
- cd "$gtkdir"
- bsdtar -zxf "$srcdir/lazarus-20140321-2.tar.gz"
- sed -e "s/\\(export\\ lazbuild=\\).*/\\1\"\$(which lazbuild) --primary-config-path=${gtkdir//\//\\\/}\/lazarus\/lazarus-$CARCH\"/" -i build.sh
- sed -e "s/%%SRCDIR%%/${gtkdir//\//\\\/}/g" -i lazarus/packagefiles.xml
- ./build.sh beta gtk2
-
- msg2 'build qt'
- qtdir="$srcdir/$pkgbase-qt"
- cd "$qtdir"
- bsdtar -zxf "$srcdir/lazarus-20140321-2.tar.gz"
- sed -e "s/\\(export\\ lazbuild=\\).*/\\1\"\$(which lazbuild) --primary-config-path=${qtdir//\//\\\/}\/lazarus\/lazarus-$CARCH\"/" -i build.sh
- sed -e "s/%%SRCDIR%%/${qtdir//\//\\\/}/g" -i lazarus/packagefiles.xml
- ./build.sh beta qt
+ msg2 'build gtk'
+ cd "$srcdir/$pkgbase-gtk"
+ ./build.sh beta gtk2
+
+ msg2 'build qt4'
+ cd "$srcdir/$pkgbase-qt4"
+ ./build.sh beta qt
+ msg2 'build qt5'
+ cd "$srcdir/$pkgbase-qt5"
+ ./build.sh beta qt5
}
package_doublecmd-gtk2() {
- pkgdesc="twin-panel (commander-style) file manager (GTK), without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
- depends=('gtk2' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
- conflicts=("$pkgbase-qt" "$_pkgbase-gtk2" "$pkgbase-gtk2-libre")
- replaces=("$_pkgbase-gtk2" "$pkgbase-gtk2-libre")
- provides=("$pkgbase-gtk2-libre")
- cd "$srcdir/$pkgbase-gtk"
- ./install/linux/install.sh --install-prefix="$pkgdir"
-
- # install doc
- cd "$srcdir/$pkgbase-help-$_helpver"
- cp -a * "$pkgdir/usr/share/$pkgbase/doc/"
+ pkgdesc="twin-panel (commander-style) file manager (GTK), without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
+ depends=('gtk2' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
+ conflicts=('doublecmd-qt4' 'doublecmd-qt5')
+ cd "$srcdir/$pkgbase-gtk"
+ ./install/linux/install.sh --install-prefix="$pkgdir"
+
+ # install doc
+ cd "$srcdir/$pkgbase-help-$_helpver"
+ cp -a * "$pkgdir/usr/share/$pkgbase/doc/"
}
-package_doublecmd-qt() {
- pkgdesc="twin-panel (commander-style) file manager (QT), without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
- depends=('qt4pas' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
- conflicts=("$pkgbase-gtk2" "$_pkgbase-qt" "$pkgbase-qt-libre")
- replaces=("$_pkgbase-qt" "$pkgbase-qt-libre")
- provides=("$pkgbase-qt-libre")
- cd "$srcdir/$pkgbase-qt"
- ./install/linux/install.sh --install-prefix="$pkgdir"
-
- # install doc
- cd "$srcdir/$pkgbase-help-$_helpver"
- cp -a * "$pkgdir/usr/share/$pkgbase/doc/"
+package_doublecmd-qt4() {
+ pkgdesc="twin-panel (commander-style) file manager (QT4), without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
+ depends=('qt4pas' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
+ conflicts=('doublecmd-gtk2' 'doublecmd-qt5')
+ replaces=('doublecmd-qt')
+ cd "$srcdir/$pkgbase-qt4"
+ ./install/linux/install.sh --install-prefix="$pkgdir"
+
+ # install doc
+ cd "$srcdir/$pkgbase-help-$_helpver"
+ cp -a * "$pkgdir/usr/share/$pkgbase/doc/"
}
+package_doublecmd-qt5() {
+ pkgdesc="twin-panel (commander-style) file manager (QT5), without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
+ depends=('qt5pas' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
+ conflicts=('doublecmd-gtk2' 'doublecmd-qt4')
+ cd "$srcdir/$pkgbase-qt5"
+ ./install/linux/install.sh --install-prefix="$pkgdir"
+
+ # install doc
+ cd "$srcdir/$pkgbase-help-$_helpver"
+ cp -a * "$pkgdir/usr/share/$pkgbase/doc/"
+}