summaryrefslogtreecommitdiff
path: root/libre/debhelper/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-04-12 13:53:12 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-04-12 13:53:12 -0300
commita0a5078595f0fc0826387582bb0e76cb52908518 (patch)
tree8d8155b80f925068f69ee4aea606a9f24d890aeb /libre/debhelper/PKGBUILD
parenta19cbf2e94f0c06adafec2a9ff0d1d619881cc83 (diff)
parent96df1bacd54ae9d919c62f4348cc011c961f923e (diff)
downloadabslibre-a0a5078595f0fc0826387582bb0e76cb52908518.tar.gz
abslibre-a0a5078595f0fc0826387582bb0e76cb52908518.tar.bz2
abslibre-a0a5078595f0fc0826387582bb0e76cb52908518.zip
Merge branch 'master' of ssh://gparabola/abslibre
Conflicts: libre/file-roller-libre/PKGBUILD
Diffstat (limited to 'libre/debhelper/PKGBUILD')
-rw-r--r--libre/debhelper/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/libre/debhelper/PKGBUILD b/libre/debhelper/PKGBUILD
new file mode 100644
index 000000000..60ff8f267
--- /dev/null
+++ b/libre/debhelper/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer (AUR): Antoine Lubineau <antoine@lubignon.info>
+# Contributor (AUR): Andrei "Garoth" Thorp <garoth@gmail.com>
+# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
+
+_debrepo=http://ftp.debian.org/debian/pool/main/ # Debian Sid
+debfile() { echo -n "$_debrepo"; echo -n "$@"|sed -r 's@(.).*@\1/&@'; }
+
+pkgname=debhelper
+pkgver=9.20120322
+pkgrel=1
+pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
+arch=('any')
+url="http://packages.debian.org/${pkgname}"
+license='GPL3'
+depends=('binutils' 'dpkg' 'file' 'html2text' 'man-db' 'perl')
+makedepends=('po4a')
+source=(`debfile ${pkgname}`/${pkgname}_$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('9ea56782e6396a59ec49f45f9c4a603f')