summaryrefslogtreecommitdiff
path: root/libre/clementine-libre/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 01:39:21 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 01:39:21 -0300
commit035f2fd609cd247ac0430f15cad3af94ce79f5f8 (patch)
treee370cdaffe855596877f25cb769922090ca2e2aa /libre/clementine-libre/PKGBUILD
parentab339da9245bbbc89d8fff20a1c114f2e2c226d3 (diff)
downloadabslibre-035f2fd609cd247ac0430f15cad3af94ce79f5f8.tar.gz
abslibre-035f2fd609cd247ac0430f15cad3af94ce79f5f8.tar.bz2
abslibre-035f2fd609cd247ac0430f15cad3af94ce79f5f8.zip
rename to clementine
Diffstat (limited to 'libre/clementine-libre/PKGBUILD')
-rw-r--r--libre/clementine-libre/PKGBUILD90
1 files changed, 0 insertions, 90 deletions
diff --git a/libre/clementine-libre/PKGBUILD b/libre/clementine-libre/PKGBUILD
deleted file mode 100644
index f34f648cb..000000000
--- a/libre/clementine-libre/PKGBUILD
+++ /dev/null
@@ -1,90 +0,0 @@
-# $Id: PKGBUILD 117584 2014-08-18 23:42:44Z alucryd $
-# Maintainer (Arch): Maxime Gauduin <alucryd@gmail.com>
-# Contributor (Arch): Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor (Arch): BlackEagle <ike.devolder@gmail.com>
-# Contributor (Arch): Dany Martineau <dany.luc.martineau@gmail.com>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Kete <kete@ninthfloor.org>
-# Contributor: Márcio Silva <coadde@parabola.nu>
-
-_pkgname=clementine
-pkgname=clementine-libre
-pkgver=1.2.3
-pkgrel=2
-pkgdesc='A modern music player and library organizer, without nonfree artwork and Spotify support'
-url='http://www.clementine-player.org/'
-license=('GPL')
-arch=('i686' 'x86_64' 'mips64el')
-replaces=('clementine')
-conflicts=('clementine')
-provides=("clementine=$pkgver")
-depends=('chromaprint' 'glew' 'gstreamer0.10-base' 'libcdio' 'libgpod' 'liblastfm' 'libmtp' 'libmygpo-qt' 'protobuf' 'qca-ossl' 'taglib')
-makedepends=('cmake' 'boost' 'mesa' 'sparsehash')
-optdepends=('gstreamer0.10-base-plugins: "Base" plugin libraries'
- 'gstreamer0.10-good-plugins: "Good" plugin libraries'
- 'gstreamer0.10-bad-plugins: "Bad" plugin libraries'
- 'gstreamer0.10-ugly-plugins: "Ugly" plugin libraries'
- 'gvfs: Various devices support')
-install="${_pkgname}.install"
-mksource=("${_pkgname}-${pkgver}.tar.gz::https://github.com/clementine-player/Clementine/archive/${pkgver}.tar.gz"
- 'remove-nonfree-artwork-and-spotify.patch'
- 'moognu.png')
-source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- 'udisks-namespace.patch')
-mksha256sums=('7df5650445a005c09f5f0e1a1b0d077037c37ecbe4ee77baf9d45f121308a1bf'
- '48bfbf42c84ac1891021638627c10780194fcc59eda1c69e157be3aebe8ee10b'
- 'c6918617769152f3617c61f721819e69d03f671b85760b11cfe45abd53955bc4')
-sha256sums=('c68275373b839b5b256b813b5bed85d501f94e12bef3dd8ed69e90094af3f769'
- 'a7c2764576cee303a57e4efe6a5dbd583a66de8a15aee738bd92d4bb21786008')
-
-mksource() {
- cd Clementine-${pkgver}
-
- # remove nonfree nonfree artwork and spotify references on files
- patch -Np1 -i ../remove-nonfree-artwork-and-spotify.patch
-
- # remove nonfree spotifyblob folders
- rm -rv ext/{clementine-spotifyblob,libclementine-spotifyblob}
-
- # remove nonfree spotify files
- rm -v cmake/SpotifyVersion.cmake
- rm -v data/spotify-attribution.png
- rm -v data/icons/svg/spotify.svg
- rm -v data/schema/schema-30.sql
- rm -v src/{globalsearch/spotifysearchprovider.{cpp,h},internet/spotify{blobdownloader.{cpp,h},server.{cpp,h},service.{cpp,h},settingspage.{cpp,h,ui}}}
-
- ## remove nonfree nyancat.png
- rm -v data/nyancat.png
-
- ## rut moognu.png to the source code
- install -m644 -v ../moognu.png data
-
- # create a blank file due which is a dependency for clementine
- touch data/schema/schema-30.sql
-}
-
-prepare() {
- cd Clementine-${pkgver}
-
- patch -Np1 -i ../udisks-namespace.patch
-}
-
-build() {
- cd Clementine-${pkgver}
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- cmake .. -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_BUILD_TYPE='Release'
- make
-}
-
-package() {
- cd Clementine-${pkgver}/build
-
- make DESTDIR="${pkgdir}" install
-}
-
-# vim: ts=2 sw=2 et: