summaryrefslogtreecommitdiff
path: root/libre/claws-mail-libre/PKGBUILD
diff options
context:
space:
mode:
authorMichał Masłowski <mtjm@mtjm.eu>2013-02-01 22:28:18 +0100
committerMichał Masłowski <mtjm@mtjm.eu>2013-02-01 22:28:18 +0100
commit0eb069f3b02f788043d7d6c32d536f18d6e2744b (patch)
tree0b739529bcd57aa8632a039e8a0834c04cf2c8b8 /libre/claws-mail-libre/PKGBUILD
parent984519b53d8ed46486460f632fbcf52c39ee6b57 (diff)
downloadabslibre-0eb069f3b02f788043d7d6c32d536f18d6e2744b.tar.gz
abslibre-0eb069f3b02f788043d7d6c32d536f18d6e2744b.tar.bz2
abslibre-0eb069f3b02f788043d7d6c32d536f18d6e2744b.zip
Fix claws-mail-libre build on mips64el.
Valgrind is not available yet. Don't use setarch $CARCH, it's useful only on x86 (we don't have a MIPS32 port and the kernel architecture names are different than $CARCH) and could be handled outside the PKGBUILD.
Diffstat (limited to 'libre/claws-mail-libre/PKGBUILD')
-rw-r--r--libre/claws-mail-libre/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/libre/claws-mail-libre/PKGBUILD b/libre/claws-mail-libre/PKGBUILD
index 7a093b29a..ee7019130 100644
--- a/libre/claws-mail-libre/PKGBUILD
+++ b/libre/claws-mail-libre/PKGBUILD
@@ -32,8 +32,8 @@ makedepends=(
bogofilter
compface
spamassassin
- valgrind
)
+[ "$CARCH" != "mips64el" ] && makedepends+=(valgrind)
optdepends=(
'python2: needed for some tools'
'perl: needed for some tools'
@@ -67,7 +67,7 @@ build() {
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
- setarch $CARCH ./configure --prefix=/usr\
+ ./configure --prefix=/usr\
--disable-dillo-viewer-plugin\
--disable-static\
--enable-bogofilter-plugin\
@@ -79,16 +79,16 @@ build() {
--enable-pgpmime-plugin\
--enable-spamassassin-plugin
- setarch $CARCH make
+ make
}
package() {
cd $srcdir/$pkgbase-$pkgver
- setarch $CARCH make DESTDIR=$pkgdir install
+ make DESTDIR=$pkgdir install
# build and install extra tools
cd tools
- setarch $CARCH make
+ make
# all executables and .conf files ; only top directory
find -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i ; do
install -D -m755 $i $pkgdir/usr/lib/$pkgbase/tools/$i