summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-26 18:39:58 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-26 18:39:58 -0500
commitd8bc7fa557ab17d89c19feadc5e657cb6ce5ff61 (patch)
treed537ed92f4750c1f0633c1d5abb452e4a13001ac /libre/calibre/PKGBUILD
parent563fa50fc03adfee619229856db0ddf215d5bf79 (diff)
downloadabslibre-d8bc7fa557ab17d89c19feadc5e657cb6ce5ff61.tar.gz
abslibre-d8bc7fa557ab17d89c19feadc5e657cb6ce5ff61.tar.bz2
abslibre-d8bc7fa557ab17d89c19feadc5e657cb6ce5ff61.zip
calibre-3.46.0-1.par1: updating version
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD47
1 files changed, 24 insertions, 23 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index 97718c83b..4e6ce9ad1 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -15,33 +15,33 @@
# - removed decrompession engine for rar archives
pkgname=calibre
-pkgver=3.39.1
+pkgver=3.46.0
pkgrel=1
-pkgrel+=.par2
+pkgrel+=.par1
pkgdesc="Ebook management application"
pkgdesc+=", without nonfree decompression engine for RAR archives"
arch=('x86_64')
arch+=('i686' 'armv7h')
url="https://calibre-ebook.com/"
license=('GPL3')
-depends=('python2-six' 'python2-dateutil' 'python2-css-parser' 'python2-dukpy'
- 'python2-mechanize' 'podofo' 'libwmf' 'jxrlib' 'mathjax'
- 'chmlib' 'python2-lxml' 'libusbx' 'python2-html5-parser'
- 'python2-pillow' 'shared-mime-info' 'python2-dnspython' 'python2-msgpack'
- 'python2-pyqt5' 'python2-psutil' 'icu' 'libmtp' 'python2-dbus'
- 'python2-netifaces' 'python2-cssselect' 'python2-apsw' 'qt5-webkit'
- 'qt5-svg' 'python2-regex' 'python2-pygments' 'mtdev'
- 'desktop-file-utils' 'gtk-update-icon-cache' 'optipng' 'udisks2')
-makedepends=('qt5-x11extras' 'sip' 'xdg-utils')
+_py_deps=('apsw' 'beautifulsoup4' 'cssselect' 'css-parser' 'dateutil' 'dbus' 'dnspython' 'dukpy'
+ 'feedparser' 'html2text' 'html5-parser' 'lxml' 'markdown' 'mechanize' 'msgpack'
+ 'netifaces' 'pillow' 'psutil' 'pygments' 'pyqt5' 'regex')
+depends=('chmlib' 'icu' 'jxrlib' 'libmtp' 'libusbx' 'libwmf' 'mathjax' 'mtdev' 'optipng'
+ 'podofo' "${_py_deps[@]/#/python2-}" 'qt5-svg' 'qt5-webkit' 'udisks2')
+makedepends=('qt5-x11extras' 'rapydscript-ng' 'sip' 'xdg-utils')
checkdepends=('xorg-server-xvfb')
optdepends=('ipython2: to use calibre-debug'
'poppler: required for converting pdf to html')
source=("https://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
"https://calibre-ebook.com/signatures/${pkgname}-${pkgver}.tar.xz.sig"
'libre.patch')
-sha256sums=('50bb56ca9455464495c646688722cb07199ed74a3a2eb3dc4f3b3e609be68121'
+sha256sums=('e947b9854f9db344ee07e5495feaad759c96936d89a128d3a3587c3503d09ab6'
'SKIP'
- '2990c382bcfaa36e3162261eed9acae7e905b75471bcdd75930ddd9a33173f6c')
+ '1574e2094ce7f3e37116215ae117ed4a10426592535b261f66eacc1508566ad2')
+b2sums=('5590ba422d0323ea7c0cea67d88d448f00f5a470e7a8fdf9851b488c0856c88175bd107715a856706e95b2e1a45604713d061f4a7a3603ecaa01dfc018c1ed58'
+ 'SKIP'
+ '45a57037ad9f9b57c73e5eed8a5faf57e2be2bfdc6f4c2ff753cc536d5f8f8431d6cc9a8d64781caab47571d45fdb4476f1fecf0e759d388ca526ad36803c19b')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C') # Kovid Goyal (New longer key) <kovid@kovidgoyal.net>
prepare(){
@@ -55,13 +55,16 @@ prepare(){
patch -fNp1 -i "$srcdir/libre.patch"
# Desktop integration (e.g. enforce arch defaults)
- sed -e "/self.create_uninstaller()/,/os.rmdir(config_dir)/d" \
- -e "/cc(\['xdg-desktop-menu', 'forceupdate'\])/d" \
- -e "/cc(\['xdg-mime', 'install', MIME\])/d" \
+ sed -e "/import config_dir/,/os.rmdir(config_dir)/d" \
-e "s/'ctc-posml'/'text' not in mt and 'pdf' not in mt and 'xhtml'/" \
-e "s/^Name=calibre/Name=Calibre/g" \
-i src/calibre/linux.py
+ # cherry-picked bits of python2-backports.functools_lru_cache
+ # needed for frozen builds + beautifulsoup4
+ # see https://github.com/kovidgoyal/calibre/commit/b177f0a1096b4fdabd8772dd9edc66662a69e683#commitcomment-33169700
+ rm -r src/backports
+
cd resources
# Remove unneeded files
@@ -95,14 +98,12 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- install -d "${pkgdir}/usr/share/zsh/site-functions" \
- "${pkgdir}"/usr/share/{applications,desktop-directories,icons/hicolor}
-
- install -Dm644 resources/calibre-mimetypes.xml \
- "${pkgdir}/usr/share/mime/packages/calibre-mimetypes.xml"
+ # If this directory doesn't exist, zsh completion won't install.
+ install -d "${pkgdir}/usr/share/zsh/site-functions"
- XDG_DATA_DIRS="${pkgdir}/usr/share" LANG='en_US.UTF-8' \
- python2 setup.py install --staging-root="${pkgdir}/usr" --prefix=/usr
+ LANG='en_US.UTF-8' python2 setup.py install \
+ --staging-root="${pkgdir}/usr" \
+ --prefix=/usr
cp -a man-pages/ "${pkgdir}/usr/share/man"