summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-24 22:04:50 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-24 22:04:50 -0300
commit543263ceb1d3636ec7d63e1635eded3e1600dade (patch)
tree0a34273c778eec87ac3b4904c476e517fcb51a93 /libre/calibre/PKGBUILD
parent130ff1dd48bf572da166d4e6a4ce7d71719aa429 (diff)
downloadabslibre-543263ceb1d3636ec7d63e1635eded3e1600dade.tar.gz
abslibre-543263ceb1d3636ec7d63e1635eded3e1600dade.tar.bz2
abslibre-543263ceb1d3636ec7d63e1635eded3e1600dade.zip
calibre-2.77.0-3.parabola1: fix build with Qt 5.8 (WIP)
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index 201500e5f..2c84e4ba4 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 208356 2017-01-22 03:42:44Z bgyorgy $
+# $Id: PKGBUILD 208674 2017-01-23 22:28:22Z arojas $
# Maintainer (Arch): Jelle van der Waa <jelle@vdwaa.nl>
# Maintainer (Arch): Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
@@ -11,7 +11,7 @@
pkgname=calibre
pkgver=2.77.0
-pkgrel=2.parabola1
+pkgrel=3.parabola1
pkgdesc="Ebook management application, without nonfree decompression engine for RAR archives"
arch=('i686' 'x86_64' 'armv7h')
url="https://calibre-ebook.com/"
@@ -33,11 +33,13 @@ conflicts=($pkgname-libre)
mksource=("http://download.$pkgname-ebook.com/${pkgver}/$pkgname-${pkgver}.tar.xz"
"https://calibre-ebook.com/signatures/${pkgname}-${pkgver}.tar.xz.sig")
source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.tar.xz"
- 'libre.patch')
+ 'libre.patch'
+ 'calibre-qt-5.8.patch')
mksha256sums=('575d1f197d5df95258ac6de3b2b7f6f8706e38d0044dbb4ae791653d229b69c0'
'SKIP')
sha256sums=('5e59e43603477983c1a272bf71f20306b2640063ab30459a4de435c99abdae91'
- '566a190f7675584acab4ceb84d504d939760a5d8644b79b4c76e68fb24515caa')
+ '566a190f7675584acab4ceb84d504d939760a5d8644b79b4c76e68fb24515caa'
+ 'a6538289b95156367a1bdb4523b58b73a56744792812ebcbdaeac26812d8f564')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C')
mksource(){
@@ -70,6 +72,9 @@ prepare(){
-e "s/'ctc-posml'/'text' not in mt and 'pdf' not in mt and 'xhtml'/" \
-e "s/^Name=calibre/Name=Calibre/g" \
-i src/calibre/linux.py
+
+ # Fix build with Qt 5.8
+ patch -p1 -i ../calibre-qt-5.8.patch
}
build() {