summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-11-08 13:43:37 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-11-08 13:43:37 -0500
commit532939ba18a14942d7e4ebc5954c706b40f97f5a (patch)
tree12c61db2a6d2dbfd0b7d336f4e2fefdc0a9347be /libre/calibre/PKGBUILD
parent462985dc147149c4257a0b9ee8a04eb8b54716ea (diff)
downloadabslibre-532939ba18a14942d7e4ebc5954c706b40f97f5a.tar.gz
abslibre-532939ba18a14942d7e4ebc5954c706b40f97f5a.tar.bz2
abslibre-532939ba18a14942d7e4ebc5954c706b40f97f5a.zip
calibre-3.33.1-2.par1: updating version
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index c9e0f8c2f..96e96370c 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer (Arch): Jelle van der Waa <jelle@vdwaa.nl>
# Maintainer (Arch): Eli Schwartz <eschwartz@archlinux.org>
# Contributor (Arch): Daniel Wallace <danielwallace at gtmanfred dot com>
@@ -10,14 +9,15 @@
# Contributor: David P.<megver83@parabola.nu>
# Contributor: Jesús E.<heckyel@parabola.nu>
# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
+# Contributor: David Palma <dbpalma9@gmail.com>
# parabola changes and rationale:
# - removed decrompession engine for rar archives
pkgname=calibre
-pkgver=3.28.0
+pkgver=3.33.1
pkgrel=2
-pkgrel+=.parabola2
+pkgrel+=.par1
pkgdesc="Ebook management application"
pkgdesc+=", without nonfree decompression engine for RAR archives"
arch=('x86_64')
@@ -25,7 +25,7 @@ arch+=('i686' 'armv7h')
url="https://calibre-ebook.com/"
license=('GPL3')
depends=('python2-six' 'python2-dateutil' 'python2-cssutils' 'python2-dukpy'
- 'python2-mechanize' 'podofo' 'libwmf'
+ 'python2-mechanize' 'podofo' 'libwmf' 'jxrlib'
'chmlib' 'python2-lxml' 'libusbx' 'python2-html5-parser'
'python2-pillow' 'shared-mime-info' 'python2-dnspython' 'python2-msgpack'
'python2-pyqt5' 'python2-psutil' 'icu' 'libmtp' 'python2-dbus'
@@ -33,22 +33,22 @@ depends=('python2-six' 'python2-dateutil' 'python2-cssutils' 'python2-dukpy'
'qt5-svg' 'python2-regex' 'python2-pygments' 'mtdev'
'desktop-file-utils' 'gtk-update-icon-cache' 'optipng' 'udisks2')
makedepends=('qt5-x11extras' 'sip' 'xdg-utils')
+checkdepends=('xorg-server-xvfb')
optdepends=('ipython2: to use calibre-debug'
- 'poppler: required for converting pdf to html'
-)
+ 'poppler: required for converting pdf to html')
source=("https://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
"https://calibre-ebook.com/signatures/${pkgname}-${pkgver}.tar.xz.sig"
'libre.patch')
-sha256sums=('241050cb89e5a70d3195cfd91ccf406919ac0bfb437e34b538c954c306d87b2c'
+sha256sums=('92bc940ac01e888058a5baa171dda8c75e9993dd419b58df3a11e3e55e3875ac'
'SKIP'
- 'f418669d2e32e917e3292350150015ed6dd13f8c2dd82ac5f1c5d20c112dd2e8')
+ '2f0d351ea3345fad6952ca15af1bbec5d88ed5b048303f4de960d5a8833868b6')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C') # Kovid Goyal (New longer key) <kovid@kovidgoyal.net>
prepare() {
cd "${pkgname}-${pkgver}"
# Remove unneeded files
- rm -rf resources/calibre-portable.*
+ rm -rf resources/${pkgname}-portable.*
# fix freedom issues
rm -v imgsrc/mimetypes/rar.svg
@@ -73,6 +73,15 @@ build() {
LANG='en_US.UTF-8' python2 setup.py gui
}
+check() {
+ cd "${pkgname}-${pkgver}"
+
+ # without xvfb-run this fails with much "Control socket failed to recv(), resetting"
+ # ERROR: test_websocket_perf (calibre.srv.tests.web_sockets.WebSocketTest)
+
+ LANG='en_US.UTF-8' xvfb-run python2 setup.py test
+}
+
package() {
cd "${pkgname}-${pkgver}"
@@ -88,6 +97,10 @@ package() {
cp -a man-pages/ "${pkgdir}/usr/share/man"
# Compiling bytecode FS#33392
- python2 -m compileall "${pkgdir}/usr/lib/calibre/"
- python2 -O -m compileall "${pkgdir}/usr/lib/calibre/"
+ # This is kind of ugly but removes traces of the build root.
+ while read -rd '' _file; do
+ _destdir="$(dirname "${_file#${pkgdir}}")"
+ python2 -m compileall -d "${_destdir}" "${_file}"
+ python2 -O -m compileall -d "${_destdir}" "${_file}"
+ done < <(find "${pkgdir}"/usr/lib/ -name '*.py' -print0)
}