summaryrefslogtreecommitdiff
path: root/libre/calibre-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-26 00:08:02 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-26 00:08:02 -0300
commit3d94323cffd8e52f9c682e619e3240a25b1c676f (patch)
tree8e0a2bc423747c4bdd012610864531aae35cff69 /libre/calibre-libre/PKGBUILD
parent4c28665a5e566d6760ef2077f1cc819fe6cf7850 (diff)
downloadabslibre-3d94323cffd8e52f9c682e619e3240a25b1c676f.tar.gz
abslibre-3d94323cffd8e52f9c682e619e3240a25b1c676f.tar.bz2
abslibre-3d94323cffd8e52f9c682e619e3240a25b1c676f.zip
calibre-libre: remove unrar files from the source
Diffstat (limited to 'libre/calibre-libre/PKGBUILD')
-rw-r--r--libre/calibre-libre/PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/libre/calibre-libre/PKGBUILD b/libre/calibre-libre/PKGBUILD
index d28dc45d1..6118642c4 100644
--- a/libre/calibre-libre/PKGBUILD
+++ b/libre/calibre-libre/PKGBUILD
@@ -27,13 +27,26 @@ replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
install=calibre.install
-source=("http://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
+mksource=("http://download.calibre-ebook.com/${pkgver}/calibre-${pkgver}.tar.xz"
+ 'libre.patch')
+source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz"
'desktop_integration.patch'
'calibre-mount-helper')
-md5sums=('1621d563c0cd46d582f8fdf8c44dbb6f'
+mkmd5sums=('1621d563c0cd46d582f8fdf8c44dbb6f'
+ '1540d92a314bf748b60b8fc436777ccb')
+md5sums=('38469886ead2808b81555ab2f505da7c'
'ece36dfd737fa4a346f0a0e59395e949'
'675cd87d41342119827ef706055491e7')
+mksource(){
+ cd "${srcdir}/${_pkgname}"
+
+ # Remove unrar files from the source
+ rm -rv src/unrar
+ rm -v src/calibre/utils/unrar.{cpp,py}
+ patch -Np1 -i "${srcdir}/libre.patch"
+}
+
prepare(){
cd "${srcdir}/${_pkgname}"
#rm -rf src/{cherrypy,pyPdf}