summaryrefslogtreecommitdiff
path: root/libre/abuse-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-09 04:39:32 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-01-09 04:39:32 -0200
commitf6fc3d982a13389b2e9937258542828e6a9d54fa (patch)
tree438a6527c3331c6682829d739953000f21a1821e /libre/abuse-libre/PKGBUILD
parent15eae1c0628fb12c17af2d78080b0553253fca21 (diff)
downloadabslibre-f6fc3d982a13389b2e9937258542828e6a9d54fa.tar.gz
abslibre-f6fc3d982a13389b2e9937258542828e6a9d54fa.tar.bz2
abslibre-f6fc3d982a13389b2e9937258542828e6a9d54fa.zip
abuse-libre-0.8-4: updating revision, add mksource and fix syntax on provides, replaces and conflicts lines
* add desktop shortcut and made it X-friendly * add missing .install file * fix default settings so they also work if running the game in a virtual installation of Parabola
Diffstat (limited to 'libre/abuse-libre/PKGBUILD')
-rw-r--r--libre/abuse-libre/PKGBUILD80
1 files changed, 58 insertions, 22 deletions
diff --git a/libre/abuse-libre/PKGBUILD b/libre/abuse-libre/PKGBUILD
index 7c99acf76..caa9fd167 100644
--- a/libre/abuse-libre/PKGBUILD
+++ b/libre/abuse-libre/PKGBUILD
@@ -1,5 +1,6 @@
-# $Id$
-# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
+# $Id: PKGBUILD 101370 2013-11-23 19:00:48Z arodseth $
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Lukas Fleischer <archlinux at cryptocrack dot de>
# Contributor: jlvsimoes <jlvsimoes@oninet.pt>
# Contributor: kevin <kevin@archlinux.org>
# Contributor (Parabola): André Silva <emulatorman@parabola.nu>
@@ -7,37 +8,72 @@
_pkgname=abuse
pkgname=abuse-libre
pkgver=0.8
-pkgrel=2
-pkgdesc='A side-scroller action game that pits you against ruthless alien killers, without nonfree claudio support'
-arch=('i686' 'x86_64')
+pkgrel=4
+pkgdesc='Side-scroller action game that pits you against ruthless alien killers, without nonfree claudio support'
+arch=('x86_64' 'i686' 'mips64l')
url='http://abuse.zoy.org/'
license=('GPL' 'custom')
-depends=('gcc-libs' 'glu' 'sdl' 'sdl_mixer')
-provides=('$_pkgname=$pkgver')
-replaces=('$_pkgname')
-conflicts=('$_pkgname')
-install='abuse.install'
-source=("http://abuse.zoy.org/raw-attachment/wiki/download/${_pkgname}-${pkgver}.tar.gz"
- non-claudio.patch)
-md5sums=('ec678b8dc8d00e0382d8c805c6438489'
- '4808c8be42f551bb3c611629a7833f09')
+provides=$_pkgname=$pkgver
+replaces=$_pkgname
+conflicts=$_pkgname
+depends=('gcc-libs' 'libgl' 'sdl_mixer' 'glu' 'desktop-file-utils')
+makedepends=('gendesk' 'mesa-libgl' 'glu')
+install="$_pkgname.install"
+mksource=("http://abuse.zoy.org/raw-attachment/wiki/download/$_pkgname-$pkgver.tar.gz"
+ 'non-claudio.patch')
+source=("https://repo.parabolagnulinux.org/sources/$pkgname-$pkgver.tar.gz"
+ 'abuse.sh'
+ 'default.abuserc'
+ 'default.gamma.lsp')
+mksha256sums=('0104db5fd2695c9518583783f7aaa7e5c0355e27c5a803840a05aef97f9d3488'
+ '017cb58acf5ba8cdb889f97a758318cb66ab4947b860a77ab16b932c3f21b98f')
+sha256sums=('ff7018b3ddcc6d2e702bc14eb2884622677ac5141c36e1fc0cdd127df3017f7d'
+ 'a5ddac71ca9b8c4bb42bdf91393a5fbe3d839ab9a9e9a6362a75dafc2aab122e'
+ '6ea2fa9e65c10bbcab4432f40d0c7284cb3970835c40c5c00ced14b39ce1b00f'
+ '13df83fea60918d29d5141cdfbd8d56147c053e88d3701209ae676f46447c2f6')
-build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+mksource() {
+ cd "abuse-$pkgver"
-# Remove the nonfree claudio addon
+ # Remove the nonfree claudio addon
rm -rvf ./data/addon/claudio
patch -Np1 -i "$srcdir/non-claudio.patch"
+}
+
+prepare() {
+ cd "abuse-$pkgver"
+
+ gendesk -n -f --_pkgname "$_pkgname" --pkgdesc "$pkgdesc"
+}
- ./configure --prefix=/usr --with-assetdir=/usr/share/abuse/orig --with-x
+build() {
+ cd "abuse-$pkgver"
+
+ ./configure --prefix=/usr --with-assetdir="/usr/share/$_pkgname/orig" --with-x
make
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "abuse-$pkgver"
+
+ make DESTDIR="$pkgdir" install
- make DESTDIR="${pkgdir}" install
+ # Desktop shortcut and icon
+ install -Dm644 "$_pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 "doc/$_pkgname.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
- install -d "${pkgdir}/usr/share/licenses/abuse"
- sed -n '1,/^$/p' src/view.cpp > "${pkgdir}/usr/share/licenses/abuse/orig.code.license"
+ # Sane defaults
+ mv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname.elf"
+ install -Dm755 "$srcdir/$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$srcdir/default.${_pkgname}rc" \
+ "$pkgdir/usr/share/$_pkgname/default.${_pkgname}rc"
+ install -Dm644 "$srcdir/default.gamma.lsp" \
+ "$pkgdir/usr/share/$_pkgname/default.gamma.lsp"
+
+ # License (for the original source code)
+ install -d "$pkgdir/usr/share/licenses/abuse"
+ sed -n '1,/^$/p' src/view.cpp > "$pkgdir/usr/share/licenses/abuse/original"
}
+
+# vim:set ts=2 sw=2 et: