summaryrefslogtreecommitdiff
path: root/libre/abiword/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-01-19 06:26:17 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-04-05 23:48:07 +0200
commit7f0026dba359718f9ac2bff2b158eabfb79444bb (patch)
treede9e47158d7f1becd55591ebd613b22aa0c6127d /libre/abiword/PKGBUILD
parent67e085b6e9984db125673a97e79fbf07011780c5 (diff)
downloadabslibre-7f0026dba359718f9ac2bff2b158eabfb79444bb.tar.gz
abslibre-7f0026dba359718f9ac2bff2b158eabfb79444bb.tar.bz2
abslibre-7f0026dba359718f9ac2bff2b158eabfb79444bb.zip
pcr: abiword: update to 3.0.4-4 by syncing with archlinux
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'libre/abiword/PKGBUILD')
-rw-r--r--libre/abiword/PKGBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/libre/abiword/PKGBUILD b/libre/abiword/PKGBUILD
index b92e4d879..7d951557b 100644
--- a/libre/abiword/PKGBUILD
+++ b/libre/abiword/PKGBUILD
@@ -5,9 +5,13 @@
# Maintainer: Andreas Grapentin <andreas@grapentin.org>
# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
+# parabola changes and rationale:
+# - Patched to replace nonfree fonts with free fonts.
+# - Built without the 'google' plugin
+
pkgname=abiword
pkgver=3.0.4
-pkgrel=1
+pkgrel=4
pkgrel+=.parabola1
pkgdesc='Fully-featured word processor'
pkgdesc+=', without Google search engine and nonfree fonts support'
@@ -18,18 +22,19 @@ url='https://www.abisource.com'
depends=('fribidi' 'wv' 'goffice' 'librsvg' 'enchant' 'desktop-file-utils'
'redland' 'libical' 'gtk-update-icon-cache' 'loudmouth' 'libwpg' 'libwps' 'libwmf' 'link-grammar'
'gtkmathview' 'aiksaurus' 'libxslt' 'libsoup' 'libots' 'libgsf' 'psiconv')
-makedepends=('pkgconfig' 'asio' 'boost' 'gobject-introspection' 'libwpd' 'libwps' 'python2-gobject' 'python-gobject' 'autoconf-archive')
+makedepends=('pkgconfig' 'boost' 'gobject-introspection' 'libwpd' 'libwps' 'python-gobject' 'autoconf-archive')
conflicts=('abiword-plugins' 'abiword-libre')
replaces=('abiword-plugins' 'abiword-libre')
options=(!makeflags)
source=(https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz{,.asc}
abiword-3.0.0-librevenge.patch
- abiword-3.0.1-libwps-0.4.patch
+ abiword-3.0.1-libwps-0.4.patch
aiksaurus-plugin.m4
command-plugin.m4
python-override.patch
enchant-2.1.patch
- liberation-fonts.patch)
+ # https://github.com/AbiWord/abiword/commit/de5dc5fd94a5fe321791d44e88d209a4972264ba
+ boost-asio.patch)
sha256sums=('e93096cb192e5bc19d62e180fc5eda643206465315a710113ae5036bc2a1a5d7'
'SKIP'
'77b52a3722096cec3bfbe4fff3802f51b6c9e0ff7aaa30028c29825fd4e6a65f'
@@ -38,8 +43,10 @@ sha256sums=('e93096cb192e5bc19d62e180fc5eda643206465315a710113ae5036bc2a1a5d7'
'2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be'
'dba1e3265cd42589f17b41fea1a39c8aa4b83c7203b9d5944b578d0ff9c858be'
'444dc2aadea3c80310a509b690097541573f6d2652c573d04da66a0f385fcfb2'
- '8a0b6e444e937924743f95c747cbe395a30fb8677a010e60c973b9039e258079')
+ '3d119595c8080f90570ce09e02d6765a0cb84b16f4cc51ef8eee4ff289c19e77')
validpgpkeys=('6C44DB3E0BF3EAF5B433239A5FEE05E6A56E15A3') # Hubert Figuiere <hub@figuiere.net>
+source+=('liberation-fonts.patch')
+sha256sums+=('8a0b6e444e937924743f95c747cbe395a30fb8677a010e60c973b9039e258079')
prepare() {
cd $pkgname-$pkgver
@@ -73,22 +80,25 @@ prepare() {
autoreconf -fi
}
+
build() {
cd $pkgname-$pkgver
- # `--enable-plugins` has the complete list of plugins, except for
- # 'command', 'gda', 'google', and 'rsvg'.
+ # `--enable-plugins` has the complete list of plugins
+ # Disabled plugins:
+ # - google: Search Google for your selected text
./configure --prefix=/usr \
--enable-shared \
--disable-static \
--enable-clipart \
--enable-templates \
- --enable-plugins="aiksaurus applix babelfish bmp clarisworks collab docbook \
- eml epub freetranslation garble gdict gimp goffice grammar \
- hancom hrtext iscii kword latex loadbindings mathview mht \
- mif mswrite opendocument openwriter openxml opml ots paint \
- passepartout pdb pdf presentation psion s5 sdw t602 urldict \
- wikipedia wmf wml wordperfect wpg xslfo" \
+ --enable-plugins="aiksaurus applix babelfish bmp clarisworks collab \
+ command docbook eml epub freetranslation garble gdict \
+ gimp goffice grammar hancom hrtext iscii kword latex \
+ loadbindings mathview mht mif mswrite opendocument \
+ openwriter openxml ots paint passepartout pdb pdf \
+ presentation psion s5 sdw t602 urldict wikipedia wmf \
+ wml wordperfect wpg xslfo" \
--enable-introspection
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
@@ -97,8 +107,4 @@ build() {
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
-
- cd src/gi-overrides
- sed -i 's/python -c/python2 -c/' Makefile
- make DESTDIR="$pkgdir" PYTHON=python2 install
}