summaryrefslogtreecommitdiff
path: root/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
diff options
context:
space:
mode:
authorIsaac David <isacdaavid@isacdaavid.info>2017-06-09 15:44:53 -0500
committerIsaac David <isacdaavid@isacdaavid.info>2017-06-09 15:44:53 -0500
commita63182bc739fa2ef86861a939898717e04cb7153 (patch)
tree28812dc1e6d2b13c2df520d1728e206bf2c75a1e /libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
parent25de18693e983c778578ab569df252911b5445e1 (diff)
downloadabslibre-a63182bc739fa2ef86861a939898717e04cb7153.tar.gz
abslibre-a63182bc739fa2ef86861a939898717e04cb7153.tar.bz2
abslibre-a63182bc739fa2ef86861a939898717e04cb7153.zip
libre-testing/uboot4extlinux-*: new versions and configs
also patch old u-boot tarballs to build with gcc7
Diffstat (limited to 'libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD')
-rw-r--r--libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD b/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
index cf16bd4f1..009cd629a 100644
--- a/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
+++ b/libre-testing/uboot4extlinux-nitrogen6q/PKGBUILD
@@ -1,7 +1,6 @@
# U-Boot: Boundary Devices Nitrogen6X/Sabre Lite
-# Maintainer: André Silva <emulatorman@parabola.nu>
-
-buildarch=4
+# Maintainer: Isaac David <isacdaavid@at@isacdaavid@dot@info>
+# Contributor: André Silva <emulatorman@parabola.nu>
pkgname=uboot4extlinux-nitrogen6q
pkgver=2014.07
@@ -17,7 +16,7 @@ install=${pkgname}.install
_commit=bb9dde563768731423fd6c560e95e1793a90710a
source=("https://github.com/boundarydevices/u-boot-imx6/archive/${_commit}.tar.gz"
'0001-parabola-arm-modifications.patch'
- '0002-kernel-add-support-for-gcc-5.patch'
+ '0002-kernel-add-support-for-gcc-7.patch'
'0003-ARM-asm-io.h-use-static-inline.patch'
'0004-common-main.c-make-show_boot_progress-__weak.patch'
'0005-common-board-use-__weak.patch'
@@ -25,7 +24,7 @@ source=("https://github.com/boundarydevices/u-boot-imx6/archive/${_commit}.tar.g
'extlinux.conf')
sha256sums=('d06ad5e6b9adb84e7bfa99f8d5335ef06d48b351809e6f65e83a92c0e8a4d3ce'
'1592a845ef7a229e5d370586edf344502f3ded5c24c853c790b600e8ef0128c7'
- '257269c4573712d3454b7c6d53d04b45af1166cb65dd9df73bd397a087f85e1e'
+ '9e80aa27cccdb07b03d56a970f247c91d586d0b936868c076c20acc2e68a3968'
'2fb98981885fbffba32fadb7b4a321e5540278c2a97f39b2700ad14c2ddb4d2a'
'83f56e80b09d010a7d0f9cc18d4df43c7f100ee3a815421f2ccbf2c337ae5431'
'bb9f0bde66266998db0eae3204346364568bab963fe7be1086d633339652b70c'
@@ -36,7 +35,7 @@ prepare() {
cd u-boot-imx6-${_commit}
patch -Np1 -i ../0001-parabola-arm-modifications.patch
- patch -Np1 -i ../0002-kernel-add-support-for-gcc-5.patch
+ patch -Np1 -i ../0002-kernel-add-support-for-gcc-7.patch
patch -Np1 -i ../0003-ARM-asm-io.h-use-static-inline.patch
patch -Np1 -i ../0004-common-main.c-make-show_boot_progress-__weak.patch
patch -Np1 -i ../0005-common-board-use-__weak.patch
@@ -45,10 +44,10 @@ prepare() {
build() {
cd u-boot-imx6-${_commit}
-
+
unset CFLAGS
unset CXXFLAGS
-
+
make distclean
make nitrogen6q_config
make