summaryrefslogtreecommitdiff
path: root/libre-testing/iproute2/PKGBUILD
diff options
context:
space:
mode:
authorBruno Cichon <ebrasca@librepanther.com>2018-10-01 01:51:03 +0200
committerBruno Cichon <ebrasca@librepanther.com>2018-10-01 01:51:03 +0200
commit56f955aca6231693fe797de4793f77ed58ab116e (patch)
tree17daeabce98174f288bab94b47961dc9e9931e66 /libre-testing/iproute2/PKGBUILD
parent75ff40baa049bae7e9270d20ef86a88b733006ab (diff)
downloadabslibre-56f955aca6231693fe797de4793f77ed58ab116e.tar.gz
abslibre-56f955aca6231693fe797de4793f77ed58ab116e.tar.bz2
abslibre-56f955aca6231693fe797de4793f77ed58ab116e.zip
Add some base packages for ppc64le
Diffstat (limited to 'libre-testing/iproute2/PKGBUILD')
-rw-r--r--libre-testing/iproute2/PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/libre-testing/iproute2/PKGBUILD b/libre-testing/iproute2/PKGBUILD
new file mode 100644
index 000000000..2dbb69516
--- /dev/null
+++ b/libre-testing/iproute2/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=iproute2
+pkgver=4.18.0
+pkgrel=1
+pkgdesc='IP Routing Utilities'
+arch=(x86_64 ppc64le)
+license=('GPL2')
+url='https://git.kernel.org/pub/scm/network/iproute2/iproute2.git'
+depends=('glibc' 'iptables' 'libelf')
+optdepends=('linux-atm: ATM support')
+groups=('base')
+provides=('iproute')
+backup=('etc/iproute2/ematch_map'
+ 'etc/iproute2/rt_dsfield'
+ 'etc/iproute2/rt_protos'
+ 'etc/iproute2/rt_realms'
+ 'etc/iproute2/rt_scopes'
+ 'etc/iproute2/rt_tables')
+makedepends=('linux-atm')
+options=('staticlibs')
+validpgpkeys=('9F6FC345B05BE7E766B83C8F80A77F6095CDE47E') # Stephen Hemminger
+source=("https://www.kernel.org/pub/linux/utils/net/${pkgname}/${pkgname}-${pkgver}.tar."{xz,sign}
+ '0001-make-iproute2-fhs-compliant.patch')
+sha256sums=('a9e6c70c95f513871c5e1f4e452c04fcb3c4d8a05be651bd794cd994a52daa45'
+ 'SKIP'
+ 'f60fefe4c17d3b768824bb50ae6416292bcebba06d73452e23f4147b46b827d3')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # set correct fhs structure
+ patch -Np1 -i "${srcdir}/0001-make-iproute2-fhs-compliant.patch"
+
+ # do not treat warnings as errors
+ sed -i 's/-Werror//' Makefile
+
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" SBINDIR="/usr/bin" install
+
+ # libnetlink isn't installed, install it FS#19385
+ install -Dm0644 include/libnetlink.h "${pkgdir}/usr/include/libnetlink.h"
+ install -Dm0644 lib/libnetlink.a "${pkgdir}/usr/lib/libnetlink.a"
+}
+