summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-11 04:46:52 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-11 04:46:52 -0300
commit9a7056bf7bbd21f46640e8b171820d021dc32a8e (patch)
tree0a66559f822a1827b966d27c21040fb7bba6a948 /kernels/linux-libre-pae/PKGBUILD
parent60cd7f09fc7a95165fe22f922c711fb47a8dd87f (diff)
downloadabslibre-9a7056bf7bbd21f46640e8b171820d021dc32a8e.tar.gz
abslibre-9a7056bf7bbd21f46640e8b171820d021dc32a8e.tar.bz2
abslibre-9a7056bf7bbd21f46640e8b171820d021dc32a8e.zip
linux-libre-{pae,xen}-3.14-4: updating version
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD114
1 files changed, 43 insertions, 71 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index c137926dc..4a6cf6215 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -1,52 +1,46 @@
-# $Id: PKGBUILD 208695 2014-03-25 06:57:17Z thomas $
+# $Id: PKGBUILD 210090 2014-04-09 19:24:57Z thomas $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
pkgbase=linux-libre-pae # Build stock -LIBRE-PAE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.13
-pkgver=${_basekernel}.8
-pkgrel=1
+_basekernel=3.14
+#pkgver=${_basekernel}.8
+pkgver=${_basekernel}
+pkgrel=4
arch=('i686')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
'boot-logo.patch'
'change-default-console-loglevel.patch'
- 'criu-no-expert.patch'
- '0001-sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch'
- '0002-sunrpc-replace-sunrpc_net-gssd_running-flag-with-a-m.patch'
- '0003-nfs-check-if-gssd-is-running-before-attempting-to-us.patch'
- '0004-rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-.patch'
- '0005-sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
- '0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch'
- '0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch'
'0001-Bluetooth-allocate-static-minor-for-vhci.patch'
- 'i8042-fix-aliases.patch')
-md5sums=('98a8e803e0ed08557f3cdd4d56b0ddc1'
- '29f02a5130dd5556f68208fa91ffe611'
- '904835a7af0bc5e88007a94cad7c1d9c'
- 'f302c931bd85309da9d9792b4cc96467'
- '44260d2cb1a8b51c119d2ce1f83e457a'
- '98beb36f9b8cf16e58de2483ea9985e3'
- '989dc54ff8b179b0f80333cc97c0d43f'
- 'dd2adb99cd3feed6f11022562901965c'
- 'b00cc399d3797cb0793e18b5bf387a50'
- '7cbd2349cdf046acc37b652c06ba36be'
- '10dbaf863e22b2437e68f9190d65c861'
- 'd5907a721b97299f0685c583499f7820'
- 'a724515b350b29c53f20e631c6cf9a14'
- 'e6fa278c092ad83780e2dd0568e24ca6'
- '06f1751777e0772c18c3fa4fbae91aa5'
- '93dbf73af819b77f03453a9c6de2bb47')
+ '0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch'
+ '0003-module-remove-MODULE_GENERIC_TABLE.patch'
+ '0004-fs-Don-t-return-0-from-get_anon_bdev.patch'
+ '0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch'
+ '0006-genksyms-fix-typeof-handling.patch'
+ '0007-Fix-the-use-of-code32_start-in-the-EFI-boot-stub.patch')
+sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
+ 'd1aa49780d3d76291dfe04d79b5b0bd9246ce101dcb7a0f6818a96c28d9d0e8e'
+ '292d5c553f87246c8dc2d57cadfd2db92a3750173b4588d53c2919743171eca5'
+ '8303b426b1a6dce456b2350003558ae312d21cab0ae6c1f0d7b9d21395f4e177'
+ 'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
+ 'aa17aa9a5c663552ea047b9d2a9a916207bed361bd387418c122f6611ee576a6'
+ '48c459a2a14e8f161b79943e9ea405c4e98cd5abdab62749c4e9d65e5735382a'
+ 'f15a6831736e4c0b8b355fd7887445e770500d439cb851623ea300cc50ba4d97'
+ '4b9aed8d0b7c2389d9413caa2152e6591200630c19dda8224d43eae7d863a0d6'
+ 'e0666f75eabc2bbfa668cb35ee72dfbad48e5963828a444fbb50388048a8cd3c'
+ 'd2c449d346ae52724d36c3224bd06fcae7775b0698a9096eb89eeaa6dbc092e5'
+ '5a175c698cfdbf942f712afeda2a6af3f4e63a742ec6b6dc3a64bc6a7fb685bb')
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE-PAE
@@ -69,33 +63,29 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # allow Checkpoint/restore (for criu) without EXPERT=y
- patch -p1 -i "${srcdir}/criu-no-expert.patch"
+ # Fix vhci warning in kmod (to restore every kernel maintainer's sanity)
+ patch -p1 -i "${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch"
- # fix 15 seconds nfs delay
- # http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=4b9a445e3eeb8bd9278b1ae51c1b3a651e370cd6
- patch -p1 -i "${srcdir}/0001-sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
- # http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=89f842435c630f8426f414e6030bc2ffea0d6f81
- patch -p1 -i "${srcdir}/0002-sunrpc-replace-sunrpc_net-gssd_running-flag-with-a-m.patch"
- # http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=6aa23d76a7b549521a03b63b6d5b7880ea87eab7
- patch -p1 -i "${srcdir}/0003-nfs-check-if-gssd-is-running-before-attempting-to-us.patch"
+ # Fix atkbd aliases
+ patch -p1 -i "${srcdir}/0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch"
+ patch -p1 -i "${srcdir}/0003-module-remove-MODULE_GENERIC_TABLE.patch"
- # fix nfs kernel oops
- # http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=3396f92f8be606ea485b0a82d4e7749a448b013b
- patch -p1 -i "${srcdir}/0004-rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-.patch"
- # http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=e2f0c83a9de331d9352185ca3642616c13127539
- patch -p1 -i "${srcdir}/0005-sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch"
- # http://git.linux-nfs.org/?p=trondmy/linux-nfs.git;a=commitdiff;h=23e66ba97127ff3b064d4c6c5138aa34eafc492f
- patch -p1 -i "${srcdir}/0006-rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-no.patch"
+ # Fix various bugs caused by rootfs having FSID 0
+ # See http://www.spinics.net/lists/kernel/msg1716924.html
+ patch -p1 -i "${srcdir}/0004-fs-Don-t-return-0-from-get_anon_bdev.patch"
- # Fix symbols: Revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=83460ec8dcac14142e7860a01fa59c267ac4657c
- patch -Rp1 -i "${srcdir}/0001-syscalls.h-use-gcc-alias-instead-of-assembler-aliase.patch"
+ # Disable usb autosuspend for intel btusb
+ # See http://www.spinics.net/lists/kernel/msg1716461.html
+ # Until a solution is found, make sure the driver leaves autosuspend alone
+ patch -p1 -i "${srcdir}/0005-Revert-Bluetooth-Enable-autosuspend-for-Intel-Blueto.patch"
- # Fix i8042 aliases
- patch -p1 -i "${srcdir}/i8042-fix-aliases.patch"
+ # Fix generation of symbol CRCs
+ # http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=dc53324060f324e8af6867f57bf4891c13c6ef18
+ patch -p1 -i "${srcdir}/0006-genksyms-fix-typeof-handling.patch"
- # Fix vhci warning in kmod (to restore every kernel maintainer's sanity)
- patch -p1 -i "${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch"
+ # Fix the use of code32_start in the EFI boot stub
+ # http://permalink.gmane.org/gmane.linux.kernel/1679881
+ patch -p1 -i "${srcdir}/0007-Fix-the-use-of-code32_start-in-the-EFI-boot-stub.patch"
cat "${srcdir}/config" > ./.config # simpler
@@ -247,25 +237,6 @@ _package-headers() {
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/lib/modules/${_kernver}/build/arch/${KARCH}/kernel/"
- # add headers for lirc package
- # pci
- for i in bt8xx cx88 saa7134; do
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/pci/${i}"
- cp -a drivers/media/pci/${i}/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/pci/${i}"
- done
- # usb
- for i in cpia2 em28xx pwc sn9c102; do
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/usb/${i}"
- cp -a drivers/media/usb/${i}/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/usb/${i}"
- done
- # i2c
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c"
- cp drivers/media/i2c/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/"
- for i in cx25840; do
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/${i}"
- cp -a drivers/media/i2c/${i}/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/${i}"
- done
-
# add docbook makefile
install -D -m644 Documentation/DocBook/Makefile \
"${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
@@ -297,6 +268,7 @@ _package-headers() {
# http://bugs.archlinux.org/task/13146
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-frontends/"
cp drivers/media/dvb-frontends/lgdt330x.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/dvb-frontends/"
+ mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/"
cp drivers/media/i2c/msp3400-driver.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/media/i2c/"
# add dvb headers