summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-24 19:04:35 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-24 19:04:35 -0200
commit6c389f1737d21a4363f96cb4187b4220018779cd (patch)
tree5fb35ade319c5bead16e7b5a34133155d5b8b75d /kernels/linux-libre-pae/PKGBUILD
parent91f24ae9b524fb2fd0313393ff917be575128748 (diff)
downloadabslibre-6c389f1737d21a4363f96cb4187b4220018779cd.tar.gz
abslibre-6c389f1737d21a4363f96cb4187b4220018779cd.tar.bz2
abslibre-6c389f1737d21a4363f96cb4187b4220018779cd.zip
linux-libre-pae-3.8-1: updating version
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index ab5c5ea24..82a888e16 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -1,12 +1,13 @@
-# $Id: PKGBUILD 178202 2013-02-18 00:58:40Z foutrelis $
+# $Id: PKGBUILD 178342 2013-02-20 12:32:29Z tpowa $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
pkgbase=linux-libre-pae # Build stock -LIBRE-PAE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.7
-pkgver=${_basekernel}.9
+_basekernel=3.8
+#pkgver=${_basekernel}.9
+pkgver=${_basekernel}
pkgrel=1
arch=('i686')
url="http://linux-libre.fsfla.org/"
@@ -14,21 +15,18 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
'boot-logo.patch'
- 'change-default-console-loglevel.patch'
- 'fat-3.6.x.patch')
-md5sums=('06bf9601d859531e7378eb43d4ca7dd3'
- 'bcffd9fa99c4db6905dc6b22d71cb17a'
- '48a1026f5d36a915b8ef68f8138a7c18'
+ 'change-default-console-loglevel.patch')
+md5sums=('84c2a77910932ffc7d958744ac9cf2f5'
+ '664e8adbc0aea7a2b546f74b1dbf1347'
'f302c931bd85309da9d9792b4cc96467'
'04b21c79df0a952c22d681dd4f4562df'
- '9d3c56a4b999c8bfbd4018089a62f662'
- '88d501404f172dac6fcb248978251560')
+ '9d3c56a4b999c8bfbd4018089a62f662')
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE-PAE
@@ -48,10 +46,6 @@ build() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix cosmetic fat issue
- # https://bugs.archlinux.org/task/32916
- patch -Np1 -i "${srcdir}/fat-3.6.x.patch"
-
cat "${srcdir}/config" > ./.config # simpler
if [ "${_kernelname}" != "" ]; then