summaryrefslogtreecommitdiff
path: root/elementary/postler/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-13 15:51:22 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-06-13 15:51:22 -0300
commit1629ba91adf00af3bd8b57dfb6cfc3fce80be218 (patch)
tree5255deb1c67e4ef538aa01045fec14d64808006f /elementary/postler/PKGBUILD
parent731bb514cd9f7c3f4ba038bfb0f69f347f42b131 (diff)
downloadabslibre-1629ba91adf00af3bd8b57dfb6cfc3fce80be218.tar.gz
abslibre-1629ba91adf00af3bd8b57dfb6cfc3fce80be218.tar.bz2
abslibre-1629ba91adf00af3bd8b57dfb6cfc3fce80be218.zip
[elementary] repo created
Diffstat (limited to 'elementary/postler/PKGBUILD')
-rw-r--r--elementary/postler/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/elementary/postler/PKGBUILD b/elementary/postler/PKGBUILD
new file mode 100644
index 000000000..55b523f82
--- /dev/null
+++ b/elementary/postler/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kosava <kosava@archlinux.us>
+
+pkgname=postler
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="Postler is simple desktop mail client built in vala"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/postler"
+license=('GPL')
+depends=('libwebkit' 'libunique' 'libcanberra' 'libnotify')
+makedepends=('vala-010' 'intltool' 'librsvg' 'gettext' 'python2' 'msmtp')
+optdepends=('dexter: provides contact completion'
+ 'lynx: enables HTML to text conversion'
+ 'libindicate: raise flags on dbus for other components of the desktop')
+install="postler.install"
+source=(http://git.xfce.org/apps/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 $pkgname.install)
+md5sums=('02e502c9f4a4b92e4ace32d9e268f06d'
+ '7541710086c2b4f45da7268c137ed708')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ export VALAC="/opt/vala-0.10/bin/valac"
+ msg "Patching the buildscript to use python2..."
+ sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|g" waf
+ ./waf configure --prefix=/usr --disable-libindicate
+ ./waf build
+ ./waf --destdir=$pkgdir install
+}