# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>

pkgname=svn-graph-branches
pkgver=0.10
pkgrel=1
pkgdesc="Parses the Subversion log of a repository to generate a graph of the important events of the project."
arch=('any')
url="https://code.google.com/p/svn-graph-branches/"
license=('GPL')
depends=('subversion' 'graphviz' 'java-environment')
makedepends=('sharutils')
source=(https://svn-graph-branches.googlecode.com/files/$pkgname-$pkgver.tar.gz)
sha1sums=('c8b85b57b7725bc869f792334505d36d527e1dea')

build() {
  cd "$srcdir/$pkgname-$pkgver"
  export CLASSPATH=`pwd`
  ./configure --prefix=/usr
  make
}

check() {
  cd "$srcdir/$pkgname-$pkgver"
  make -k check
}

package() {
  cd "$srcdir/$pkgname-$pkgver"
  make DESTDIR="$pkgdir/" install
}