# Contributor: Lukas Linhart <bugs@almad.net>
# Contributor: Changaco <changaco ατ changaco δοτ net>
# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>

pkgname=python2-argparse
pkgver=1.2.1
pkgrel=1
pkgdesc="Command line parsing library for python"
arch=('any')
url='http://code.google.com/p/argparse/'
conflicts=('argparse')
license=('Apache')
depends=('python2')
makedepends=('setuptools')
source=("http://argparse.googlecode.com/files/argparse-$pkgver.tar.gz")

# While python 2.7 has a builtin argparse module,
# packages built with setuptools still needs this one.

build() {
  cd ${srcdir}/argparse-$pkgver
  python2 setup.py build || return 1
  python2 setup.py install --root=${pkgdir} || return 1
}