# U-Boot: BeagleBone and BeagleBone Black
# Maintainer: André Silva <emulatorman@parabola.nu>

buildarch=4

pkgname=uboot-am335x_bone
pkgver=2015.04
pkgrel=1
pkgdesc="U-Boot for BeagleBone and BeagleBone Black"
arch=('armv7h')
url="http://git.denx.de/u-boot.git/"
makedepends=('git' 'bc')
depends=('linux-libre')
replaces=('uboot-beaglebone-linux-libre' 'uboot-beaglebone-linux-libre-lts'
          'uboot-beaglebone-linux-libre-grsec' 'uboot-beaglebone-linux-libre-pck'
          'uboot-beaglebone')
conflicts=('uboot4extlinux-am335x_bone' 'uboot4grub-am335x_bone')
license=('GPL')
install=${pkgname}.install
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
        '0001-parabola-arm-modifications.patch'
        'uEnv.txt')
md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
         '0196a4e91c2e7b4c0183a19cdf651c07'
         'ccb79775b81654e16fca18825c7f2506')

prepare() {
  cd u-boot-${pkgver}
  patch -Np1 -i ../0001-parabola-arm-modifications.patch
}

build() {
  cd u-boot-${pkgver}

  unset CFLAGS CXXFLAGS LDFLAGS

  make distclean
  make am335x_evm_config
  make
}

package() {
  cd u-boot-${pkgver}
  mkdir -p "${pkgdir}"/boot
  cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
}