summaryrefslogtreecommitdiff
path: root/~lukeshu/iceweasel-libre-current/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~lukeshu/iceweasel-libre-current/PKGBUILD')
-rw-r--r--~lukeshu/iceweasel-libre-current/PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/~lukeshu/iceweasel-libre-current/PKGBUILD b/~lukeshu/iceweasel-libre-current/PKGBUILD
index 9c7c4d1b3..e90b3ed8c 100644
--- a/~lukeshu/iceweasel-libre-current/PKGBUILD
+++ b/~lukeshu/iceweasel-libre-current/PKGBUILD
@@ -23,10 +23,7 @@ replaces=('firefox' 'icecat')
install=iceweasel.install
source=("${_repo_url}/iceweasel_${_debver}.orig.tar.bz2"
"${_repo_url}/iceweasel_${_debver}-${_debrel}.debian.tar.gz"
- # Misc
mozconfig
- mozilla-firefox-1.0-lang.patch
- xulrunner-copy-stub.patch
libre.patch
# Search engines
arch-linux-wiki.xml
@@ -37,8 +34,9 @@ source=("${_repo_url}/iceweasel_${_debver}.orig.tar.bz2"
yacy.xml
duck-duck-go-ssl.xml
duck-duck-go-lite.xml
- # Default options
- firefox.js
+ # Default configuration
+ mozilla-firefox-1.0-lang.patch
+ xulrunner-copy-stub.patch
region.properties)
build() {
@@ -60,21 +58,20 @@ build() {
msg2 "Applying Parabola/ConnochaetOS patches..."
cd "${srcdir}/${_pkgname}-${pkgver}/"
- patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch"
- patch -p1 < ../libre.patch
-# patch -Np0 -i "${srcdir}/xulrunner-copy-stub.patch"
+ patch -p1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch"
+ patch -p1 -i "${srcdir}/xulrunner-copy-stub.patch"
+ patch -p1 -i "${srcdir}/libre.patch"
cp --remove-destination ${srcdir}/region.properties ./browser/locales/en-US/chrome/browser-region/
msg2 "Starting build..."
- cp "${srcdir}/mozconfig" .mozconfig
+ cp "${srcdir}/mozconfig" .mozconfig
#make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}"
./configure
-
# touch config*
-
make MOZ_MAKE_FLAGS="${MAKEFLAGS}"
+
msg2 "Build complete"
}
@@ -113,8 +110,6 @@ package() {
md5sums=('bd656a24d0ba3d4ca7b68aca8081a07d'
'8846b9cce4ce7a82ec9995510efce867'
'5e2574eef71ee1437e2f8e7481c67893'
- 'bd5db57c23c72a02a489592644f18995'
- '9d5fbf6799324b6706b6c9e4ddeaf861'
'9609e77182cc300e3fe9d4b0c7e7efb4'
'3403175087e584a8c5e840cc62310cd9'
'462c68585461f8cdc23c93c46f6ee4cf'
@@ -124,5 +119,6 @@ md5sums=('bd656a24d0ba3d4ca7b68aca8081a07d'
'24528ca3f7f1e1a0ba735231aa3ac1de'
'c5f00b6b24222aacd5a749d1f59c4d24'
'e1bda0854de7d764f7401c81bb82b5ef'
- '9952048383966926eea6d67384102425'
+ 'bd5db57c23c72a02a489592644f18995'
+ 'a485a2b5dc544a8a2bd40c985d2e5813'
'f1c76e7e244257856a386ca2de69bdf0')