summaryrefslogtreecommitdiff
path: root/~fauno/geoclue/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~fauno/geoclue/PKGBUILD')
-rw-r--r--~fauno/geoclue/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/~fauno/geoclue/PKGBUILD b/~fauno/geoclue/PKGBUILD
new file mode 100644
index 000000000..e370197c7
--- /dev/null
+++ b/~fauno/geoclue/PKGBUILD
@@ -0,0 +1,28 @@
+# mAINTAIner: Isaac Dupree <id@isaac.cedarswampstudios.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Kurama <kurama_luka@yahoo.it>
+
+pkgname=geoclue
+pkgver=0.12
+pkgrel=2
+pkgdesc="Modular geoinformation service built on the D-Bus messaging system."
+arch=('i686' 'x86_64')
+url="http://geoclue.freedesktop.org"
+license=('LGPL')
+depends=('gconf')
+makedepends=('gtk-doc' 'libtool')
+source=(http://cgit.freedesktop.org/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+# unset LDFLAGS
+ ./autogen.sh --prefix=/usr --libexecdir=/usr/lib
+ find -name 'Makefile' -print0 | xargs -0 sed -i "s/-Werror //"
+ make
+}
+
+package(){
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+md5sums=('684e24d1ff3683953c968fed210b2982')