summaryrefslogtreecommitdiff
path: root/searx/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'searx/PKGBUILD')
-rw-r--r--searx/PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/searx/PKGBUILD b/searx/PKGBUILD
new file mode 100644
index 000000000..f9b6fc859
--- /dev/null
+++ b/searx/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer (AUR): Jake <aur@ja-ke.tech>
+# parabola changes and rationale:
+# - Fixed license
+# - Moved random secret key generation in the .install: having that in
+# prepare() is not obtimal even for AUR, but it still works fine in many
+# cases because users run the package on the machine that compiles it, so
+# even if it ends up in the package, it's not a big issue, unless users share
+# the package as they are not aware of this issue in the first place.
+
+pkgname=searx
+pkgver=0.16.0
+pkgrel=2
+pkgrel+=par1
+pkgdesc="A privacy-respecting, hackable metasearch engine (python(3) based)"
+arch=('any')
+url="https://asciimoo.github.io/searx/"
+license=('AGPL3')
+makedepends=('openssl')
+install="${pkgname}.install"
+depends=(
+ 'uwsgi'
+ 'uwsgi-plugin-python'
+ 'python-certifi'
+ 'python-flask'
+ 'python-flask-babel'
+ 'python-lxml'
+ 'python-idna'
+ 'python-pygments'
+ 'python-pyopenssl'
+ 'python-dateutil'
+ 'python-yaml'
+ 'python-requests'
+ 'python-pysocks')
+conflicts=('searx-git' )
+replaces=('searx-py3')
+backup=('etc/searx/settings.yml' 'etc/uwsgi/searx.ini')
+source=("https://github.com/asciimoo/searx/archive/v$pkgver.zip"
+ 'searx.ini'
+ 'searx.sysusers'
+ '0003-Fix-deprecated-werkzeug-import.patch')
+sha512sums=('3ae4e4c295830e65eefbd39ed9885b60a42a4d4db4d87c179ace76cf43f8c75d49f1363f019bedd135c0597191612e16592cacd159ae97a42a25dcc2fee9d00b'
+ '6e1e7771e747e2bcb9cbc3e5ec9735461b6d791c0c0412e06e7dd802c18625edd0916de32164bf780c18ef7b6a87f55ed1e917377b3adb2bf53c0344f34b49e8'
+ '6856e26451fe053d37c2ce4b9d5f3b35891dd8ec702c5256c02d04415124c57705abc497f12943948a85621bb0238d26c2c1f3a7bf42404a6ff1487c7655909e'
+ '064738f57b8bfbd937d56c592f7321140aab5f894e8ea457ae0d2d9407523f58471f4ba7424968f1d6db7fe51e4f8d360d1e997284eeb7b8528dbcf10f5f12dd')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/0003-Fix-deprecated-werkzeug-import.patch"
+
+ # Allow newer versions of the dependencies
+ sed -i "s|==|>=|g" requirements.txt
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ local _site_packages="$(python -c 'import site; print(site.getsitepackages()[0])')"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ mv "${pkgdir}${_site_packages}"/{README.rst,requirements*,searx}
+
+ mkdir -p "$pkgdir/etc/$pkgname"
+ mv "${pkgdir}${_site_packages}/$pkgname/settings.yml" $pkgdir/etc/$pkgname/
+ ln -s /etc/$pkgname/settings.yml "${pkgdir}${_site_packages}/$pkgname/settings.yml"
+
+ install -Dm644 "${srcdir}/searx.sysusers" "${pkgdir}/usr/lib/sysusers.d/searx.conf"
+ install -Dm644 "${srcdir}/searx.ini" "${pkgdir}/etc/uwsgi/searx.ini"
+}