summaryrefslogtreecommitdiff
path: root/pcr/toxic-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/toxic-git/PKGBUILD')
-rw-r--r--pcr/toxic-git/PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/pcr/toxic-git/PKGBUILD b/pcr/toxic-git/PKGBUILD
index c3ce125ce..80ecb0e95 100644
--- a/pcr/toxic-git/PKGBUILD
+++ b/pcr/toxic-git/PKGBUILD
@@ -1,24 +1,22 @@
-# Maintainer: freaj <freaj@riseup.net>
# Maintainer (Arch): HÃ¥vard Pettersson <mail@haavard.me>
-# Contributor (Arch): Florian Hahn <flo@fhahn.com>
+# Contributor (Arch): Florian Hahn <flo at fhahn dot com>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
_pkgname=toxic
pkgname=toxic-git
pkgdesc='CLI Frontend in ncurses for Tox'
license=('GPL3')
-pkgver=r1527.409e4dd
+pkgver=0.6.1.r3.ga920f3e
pkgrel=1
-depends=(
- 'desktop-file-utils'
- 'freealut'
- 'libnotify'
- 'tox-git'
-)
+depends=('desktop-file-utils'
+ 'freealut'
+ 'libnotify'
+ 'toxcore')
makedepends=('git')
conflicts=($_pkgname)
provides=($_pkgname)
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-url=('http://tox.im')
+arch=('i686' 'x86_64' 'armv7h')
+url=('http://tox.chat')
source=("${pkgname}::git+https://github.com/Tox/toxic.git")
sha512sums=('SKIP')
@@ -26,7 +24,7 @@ install="${pkgname}.install"
pkgver() {
cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {