summaryrefslogtreecommitdiff
path: root/pcr/strongswan/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/strongswan/PKGBUILD')
-rw-r--r--pcr/strongswan/PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/pcr/strongswan/PKGBUILD b/pcr/strongswan/PKGBUILD
index efd322184..ba83c6cd6 100644
--- a/pcr/strongswan/PKGBUILD
+++ b/pcr/strongswan/PKGBUILD
@@ -12,8 +12,8 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=strongswan
-pkgver=5.5.1
-pkgrel=5
+pkgver=5.5.2
+pkgrel=1
pkgdesc="open source IPsec implementation"
url='http://www.strongswan.org'
license=("GPL")
@@ -36,25 +36,19 @@ eap-sim.conf,eap-simaka-pseudonym.conf,eap-simaka-reauth.conf,eap-tls.conf,ext-a
fips-prf.conf,forecast.conf,gmp.conf,ha.conf,hmac.conf,kernel-netlink.conf,md5.conf,mgf1.conf,nonce.conf,newhope.conf,ntru.conf,openssl.conf,\
pem.conf,pgp.conf,pkcs1.conf,pkcs12.conf,pkcs7.conf,pkcs8.conf,pubkey.conf,random.conf,rc2.conf,resolve.conf,\
revocation.conf,sha1.conf,sha2.conf,sha3.conf,socket-default.conf,sql.conf,sqlite.conf,sshkey.conf,stroke.conf,updown.conf,\
-vici.conf,x509.conf,xauth-eap.conf,xauth-generic.conf,xcbc.conf,unity.conf}
+vici.conf,x509.conf,xauth-eap.conf,xauth-generic.conf,xcbc.conf,unity.conf,curve25519.conf}
)
source=("https://download.strongswan.org/strongswan-${pkgver}.tar.bz2"
"https://download.strongswan.org/strongswan-${pkgver}.tar.bz2.sig"
"configure_ac.patch"
- "2222-charon-systemd-sighup.patch"
- "2238-eap-dynamic-auth.patch"
)
validpgpkeys=("948F158A4E76A27BF3D07532DF42C170B34DBA77")
-# md5 is broken. We use sha256 now. Alternatively, we could check the signature of the file, but that
-# doesn't yield any more security and just increases the work users initially have to invest.
-sha256sums=('720b301991f77bdedd8d551a956f52e2d11686a0ec18e832094f86cf2b842ab7'
+sha256sums=('da976fca836f05fc7b7a38baab299745f960cb7640319969d239d8aa4ace9f6a'
'SKIP'
- '003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7'
- 'SKIP'
- 'SKIP')
+ '003750d77fa501075f1fdb6f55926dc544407c5dd26e2fd8d5eb4917ddf0b3f7')
# We don't build libipsec because it would get loaded before kernel-netlink and netkey, which
# would case processing to be handled in user space. Also, the plugin is experimental. If you need it,
@@ -63,8 +57,6 @@ prepare()
{
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -l < "${srcdir}/configure_ac.patch"
- patch -p1 -l < "${srcdir}/2222-charon-systemd-sighup.patch"
- patch -p1 -l < "${srcdir}/2238-eap-dynamic-auth.patch"
autoreconf
}
@@ -76,6 +68,7 @@ build() {
--sysconfdir=/etc \
--libexecdir=/usr/lib \
--with-ipsecdir=/usr/lib/strongswan \
+ --with-nm-ca-dir=/etc/ssl/certs \
--enable-sqlite \
--enable-openssl --enable-curl \
--enable-sql --enable-attr-sql \
@@ -89,7 +82,7 @@ build() {
--enable-aesni --enable-eap-ttls --enable-radattr --enable-xauth-pam --enable-xauth-noauth \
--enable-eap-dynamic --enable-eap-peap --enable-eap-tls --enable-chapoly --enable-unity \
--with-capabilities=libcap --enable-newhope --enable-ntru --enable-mgf1 --enable-sha3 \
- --enable-bliss
+ --enable-bliss --enable-dnscert
# if you want networkmanager support, add --enable-nm
# --enable-ruby-gems --enable-python-eggs
make