summaryrefslogtreecommitdiff
path: root/pcr/snort/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/snort/PKGBUILD')
-rw-r--r--pcr/snort/PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/pcr/snort/PKGBUILD b/pcr/snort/PKGBUILD
index c7cf8772f..8ab0931ee 100644
--- a/pcr/snort/PKGBUILD
+++ b/pcr/snort/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=snort
pkgver=2.9.7.0
-pkgrel=1
+pkgrel=3
pkgdesc='A lightweight network intrusion detection system.'
arch=('i686' 'x86_64' 'mips64el')
url='http://www.snort.org'
@@ -20,18 +20,15 @@ backup=('etc/snort/snort.conf'
'etc/snort/classification.config')
options=('!makeflags' '!libtool')
install='snort.install'
-source=("http://www.${pkgname}.org/downloads/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+source=("https://www.snort.org/downloads/snort/${pkgname}-${pkgver}.tar.gz"
"http://rules.emergingthreats.net/open/${pkgname}-2.9.0/emerging.rules.tar.gz"
- 'snort.service')
-md5sums=('c2a45bc56441ee9456478f219dd8d1e2'
- '183bf888ede30967ac0ebc3f046097cf'
- '43ed16fd3906854528a62a58f88f7227')
+ 'snort@.service')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc/snort --with-libpcap-includes=/usr/include/pcap \
--with-daq-includes=/usr/include --with-daq-libraries=/usr/lib/ \
- --enable-zlib --disable-static-daq
+ --disable-static-daq
make
}
@@ -46,7 +43,7 @@ package() {
install -D -m644 etc/{*.conf*,*.map} "${pkgdir}/etc/snort/"
# init service file
- install -D -m644 ../snort.service $pkgdir/usr/lib/systemd/system/snort.service
+ install -D -m644 ../snort@.service $pkgdir/usr/lib/systemd/system/snort@.service
sed -i 's#/usr/local/lib/#/usr/lib/#' "${pkgdir}/etc/snort/snort.conf"
@@ -55,3 +52,6 @@ package() {
cp ${srcdir}/rules/* "${pkgdir}/etc/snort/rules"
}
+md5sums=('c2a45bc56441ee9456478f219dd8d1e2'
+ 'SKIP'
+ '49c7e8dbde680322ff5c4e0883f2b908')