summaryrefslogtreecommitdiff
path: root/pcr/shotcut/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/shotcut/PKGBUILD')
-rw-r--r--pcr/shotcut/PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/pcr/shotcut/PKGBUILD b/pcr/shotcut/PKGBUILD
index 4e15766eb..4b39020c1 100644
--- a/pcr/shotcut/PKGBUILD
+++ b/pcr/shotcut/PKGBUILD
@@ -1,10 +1,12 @@
+# shellcheck disable=SC2034,SC2154,SC2164
pkgname=('shotcut')
_srcname='shotcut'
pkgdesc='Video editor'
-pkgver='16.08'
+pkgver='17.04'
+_commit='8de07dafef1d3685f902f6298d00bc5f746e12f6'
pkgrel='1'
arch=('i686' 'x86_64')
-url='https://github.com/mltframework/shotcut'
+url='https://www.shotcut.org/'
license=('GPL3')
depends=(
@@ -29,7 +31,7 @@ provides=("${pkgname[0]%-git}")
conflicts=("${pkgname[0]%-git}")
source=(
- "${_srcname}::git+${url}.git#tag=v${pkgver}"
+ "${_srcname}::git+https://github.com/mltframework/shotcut.git#commit=${_commit}"
'shotcut.desktop'
'melt.patch'
)
@@ -48,7 +50,7 @@ prepare() {
build() {
cd "${srcdir}/${_srcname}"
- qmake 'CONFIG-=c++11' PREFIX='/usr/'
+ qmake PREFIX='/usr/'
make
}