summaryrefslogtreecommitdiff
path: root/pcr/shotcut/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/shotcut/PKGBUILD')
-rw-r--r--pcr/shotcut/PKGBUILD70
1 files changed, 0 insertions, 70 deletions
diff --git a/pcr/shotcut/PKGBUILD b/pcr/shotcut/PKGBUILD
deleted file mode 100644
index 8096934f3..000000000
--- a/pcr/shotcut/PKGBUILD
+++ /dev/null
@@ -1,70 +0,0 @@
-
-# parabola changes and rationale:
-# no changes.
-
-# shellcheck disable=SC2034,SC2154,SC2164
-pkgname=('shotcut')
-_srcname='shotcut'
-pkgdesc='Video editor'
-pkgver='18.01'
-_commit='5d86a8616a29cd8cf4d7d69794b70551c5de8bf4'
-pkgrel='1'
-arch=('i686' 'x86_64' 'armv7h')
-url='https://www.shotcut.org/'
-license=('GPL3')
-
-depends=(
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-graphicaleffects'
- 'qt5-multimedia'
- 'qt5-quickcontrols'
- 'qt5-webkit'
- 'qt5-websockets'
- 'qt5-x11extras'
- 'mlt'
- 'movit'
- 'ffmpeg'
- 'libx264'
- 'libvpx'
- 'lame'
- 'frei0r-plugins'
- 'ladspa'
-)
-makedepends=('git')
-provides=("${pkgname[0]%-git}")
-conflicts=("${pkgname[0]%-git}")
-
-source=(
- "${_srcname}::git+https://github.com/mltframework/shotcut.git#commit=${_commit}"
- 'shotcut.desktop'
- 'melt.patch'
-)
-sha512sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
-
-prepare() {
- cd "${srcdir}/${_srcname}"
-
- git apply "${srcdir}/melt.patch"
-}
-
-build() {
- cd "${srcdir}/${_srcname}"
-
- qmake PREFIX='/usr' \
- QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
- QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"
- make
-}
-
-package() {
- cd "${srcdir}/${_srcname}"
-
- make INSTALL_ROOT="${pkgdir}" install
-
- install -D --mode=644 "${srcdir}/shotcut.desktop" "${pkgdir}/usr/share/applications/shotcut.desktop"
-}