summaryrefslogtreecommitdiff
path: root/pcr/qgis/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/qgis/PKGBUILD')
-rw-r--r--pcr/qgis/PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/pcr/qgis/PKGBUILD b/pcr/qgis/PKGBUILD
index cee9c291f..f76848c8f 100644
--- a/pcr/qgis/PKGBUILD
+++ b/pcr/qgis/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer (Arch): Doug Newgard <scimmia at archlinux dot info>
+# Maintainer (Arch): XavierCLL <xavier.corredor.llano (a) gmail.com>
# Contributor (Arch): SaultDon <sault.don gmail>
-# Contributor: (Arch) Lantald < lantald at gmx.com >
+# Contributor (Arch): Lantald < lantald at gmx.com >
# Contributor (Arch): Thomas Dziedzic < gostrc at gmail >
# Contributor (Arch): dibblethewrecker dibblethewrecker.at.jiwe.dot.org
# Contributor (Arch): Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
# Contributor (Arch): Eric Forgeot < http://esclinux.tk >
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-# Globe Plugin and QGIS Map Server are disabled in cmake by default.
+# Globe Plugin and Map Server are disabled in cmake by default.
# Uncomment them in the build() portion if you'd like them enabled.
# You will also need to install osgearth or fcgi, respectively, before building.
pkgname=qgis
-pkgver=2.12.0
-pkgrel=2.parabola1
-pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
+pkgver=2.12.1
+pkgrel=1.parabola1
+pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats, without nonfree ElvenSword resource'
url='http://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
@@ -25,12 +26,10 @@ makedepends=('cmake' 'txt2tags' 'perl')
optdepends=('gpsbabel: GPS Tool plugin')
install="$pkgname.install"
mksource=("http://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.tar.gz"
- "console_pyqt4.diff"
+source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.tar.bz2"
"libre.patch")
-mkmd5sums=('099efb9482a67e3c57f54f4947986e39')
-md5sums=('4f1122610833228e6952028a4f29ba45'
- '636b0fd147d19f50e82080a5819ae10a'
+mkmd5sums=('b47a7e040341164fd2b8f7970055e3d0')
+md5sums=('9399b11476a6df55e3446b1bb6101679'
'6c5f082d7f41f45762030a80aa89d5ff')
mksource() {
@@ -43,11 +42,17 @@ mksource() {
prepare() {
cd $pkgname-$pkgver
- patch -Np1 -i "$srcdir/console_pyqt4.diff"
+ patch -Np1 -i "$srcdir/libre.patch"
# Fixing shebang for .py files
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
+ # Fix console.py for new pyqt build system
+ sed -e '/from PyQt4.QtCore/ s/$/, QT_VERSION/' \
+ -e '/import pyqtconfig/d' \
+ -e 's/pyqtconfig.*qt_version/QT_VERSION/' \
+ -i python/console/console.py
+
[[ -d build ]] || mkdir build
}
@@ -83,9 +88,9 @@ package() {
[[ -n "$(awk -F= '/^GRASS_PREFIX7:/ {print $2}' build/CMakeCache.txt)" ]] && \
optdepends+=('grass: GRASS7 plugin')
[[ "$(awk -F= '/^WITH_SERVER:/ {print $2}' build/CMakeCache.txt)" == "TRUE" ]] && \
- optdepends+=('fcgi: QGIS Map Server')
+ optdepends+=('fcgi: Map Server')
[[ "$(awk -F= '/^WITH_GLOBE:/ {print $2}' build/CMakeCache.txt)" == "TRUE" ]] && \
- optdepends+=('osgearth: QGIS Globe plugin')
+ optdepends+=('osgearth: Globe plugin')
make -C build DESTDIR="$pkgdir" install