summaryrefslogtreecommitdiff
path: root/pcr/python-pyspf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python-pyspf/PKGBUILD')
-rw-r--r--pcr/python-pyspf/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/pcr/python-pyspf/PKGBUILD b/pcr/python-pyspf/PKGBUILD
new file mode 100644
index 000000000..9a256215d
--- /dev/null
+++ b/pcr/python-pyspf/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
+# Maintainer (AUR): Rich Li <rich@dranek.com>
+# Contributor (AUR): Samed Beyribey <ras0ir@eventualis.org>
+
+_pkgname=pyspf
+pkgname=python-$_pkgname
+_basever=2.0.12
+_patchver=t
+_pkgver=${_basever}${_patchver}
+pkgver=${_basever}.${_patchver}
+pkgdesc="Python implementation of the Sender Policy Framework (SPF) protocol"
+url="https://pypi.python.org/pypi/pyspf"
+license=('PSF')
+source=("https://pypi.python.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$_pkgver.tar.gz")
+md5sums=('c83143ad79074bf8c80235748a8a698f')
+
+pkgrel=1
+arch=('any')
+depends=('python-py3dns')
+makedepends=('python-setuptools')
+optdepends=('python-authres: Return RFC 5451 Authentication Results headers')
+
+package() {
+ cd "$srcdir/$_pkgname-${_basever}"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+}