summaryrefslogtreecommitdiff
path: root/pcr/prboom-plus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/prboom-plus/PKGBUILD')
-rw-r--r--pcr/prboom-plus/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pcr/prboom-plus/PKGBUILD b/pcr/prboom-plus/PKGBUILD
new file mode 100644
index 000000000..e0555f122
--- /dev/null
+++ b/pcr/prboom-plus/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer (AUR): Kingan <kingan201 at gmail dot com>
+# Contributor (AUR): Frederic Bezies <fredbezies at gmail dot com>
+# Contributor (AUR): Valsu [arch(at)hylia.de]
+
+pkgname=prboom-plus
+pkgver=2.5.1.4
+pkgrel=1
+pkgdesc='An advanced, Vanilla-compatible Doom engine based on PrBoom'
+url='http://prboom-plus.sourceforge.net/'
+arch=('x86_64' 'i686')
+arch+=('armv7h')
+license=('GPL2')
+depends=('fluidsynth' 'glu' 'libmad' 'portmidi' 'sdl_image' 'sdl_mixer' 'sdl_net')
+conflicts=('prboom')
+replaces=('prboom')
+provides=('prboom')
+source=("http://download.sourceforge.net/prboom-plus/prboom-plus-$pkgver.tar.gz")
+sha256sums=('e0e2241d174839b107f1a42b191aa9895dc6749e477cbc850ad520fba2353b94')
+
+build() {
+ cd "prboom-plus-$pkgver"
+
+ ./configure --prefix=/usr --without-dumb
+ make
+}
+
+package() {
+ cd "prboom-plus-$pkgver"
+
+ make DESTDIR="$pkgdir" gamesdir=/usr/bin install
+}