summaryrefslogtreecommitdiff
path: root/pcr/prboom-plus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/prboom-plus/PKGBUILD')
-rw-r--r--pcr/prboom-plus/PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/pcr/prboom-plus/PKGBUILD b/pcr/prboom-plus/PKGBUILD
index e0555f122..c5f73e8eb 100644
--- a/pcr/prboom-plus/PKGBUILD
+++ b/pcr/prboom-plus/PKGBUILD
@@ -2,9 +2,16 @@
# Contributor (AUR): Frederic Bezies <fredbezies at gmail dot com>
# Contributor (AUR): Valsu [arch(at)hylia.de]
+# parabola changes and rationale:
+# - use --disable-cpu-opt, otherwise it use -mach=native and the resulting
+# binary is only meant to run on the machine that compiled it: this option
+# generates SMID (SSE3, AVX, etc) instructions in a way that is impossible to
+# disable it at runtime. So running it on a machine without the same extended
+# instruction set generally result in illegal instructions.
+
pkgname=prboom-plus
pkgver=2.5.1.4
-pkgrel=1
+pkgrel=2
pkgdesc='An advanced, Vanilla-compatible Doom engine based on PrBoom'
url='http://prboom-plus.sourceforge.net/'
arch=('x86_64' 'i686')
@@ -20,7 +27,7 @@ sha256sums=('e0e2241d174839b107f1a42b191aa9895dc6749e477cbc850ad520fba2353b94')
build() {
cd "prboom-plus-$pkgver"
- ./configure --prefix=/usr --without-dumb
+ ./configure --prefix=/usr --without-dumb --disable-cpu-opt
make
}