summaryrefslogtreecommitdiff
path: root/pcr/opentmpfiles/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/opentmpfiles/PKGBUILD')
-rw-r--r--pcr/opentmpfiles/PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/pcr/opentmpfiles/PKGBUILD b/pcr/opentmpfiles/PKGBUILD
index 9a8e31760..391c3928d 100644
--- a/pcr/opentmpfiles/PKGBUILD
+++ b/pcr/opentmpfiles/PKGBUILD
@@ -2,18 +2,20 @@
# Contributor (Manjaro): williamh <williamh@gentoo.org>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+_sed_args+=(-e 's|#!/sbin/runscript|#!/usr/bin/openrc-run|g')
+
pkgname=opentmpfiles
pkgver=0.1.3
-pkgrel=2
+pkgrel=2.1
pkgdesc="A standalone utility for handling systemd-style tmpfiles.d settings"
arch=('any')
-url="https://github.com/OpenRC/opentmpfiles/archive"
+url="https://github.com/OpenRC/opentmpfiles"
license=('BSD2')
groups=('openrc-base')
depends=('openrc')
backup=('etc/conf.d/opentmpfiles-dev'
'etc/conf.d/opentmpfiles-setup')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('1fdd4587c62d815296fb4162002cf001e3ed7aae8727d9b4360f527169e6b3be')
_inst_initd(){
@@ -22,6 +24,8 @@ _inst_initd(){
_inst_confd(){
install -Dm755 openrc/$1.confd ${pkgdir}/etc/conf.d/$1
+
+ sed "${_sed_args[@]}" -i ${pkgdir}/etc/conf.d/$1
}
package() {