summaryrefslogtreecommitdiff
path: root/pcr/light-locker-consolekit/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/light-locker-consolekit/PKGBUILD')
-rw-r--r--pcr/light-locker-consolekit/PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/pcr/light-locker-consolekit/PKGBUILD b/pcr/light-locker-consolekit/PKGBUILD
deleted file mode 100644
index c9cfae939..000000000
--- a/pcr/light-locker-consolekit/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Maintainer (Arch): Aaditya Bagga <aaditya_gnulinux@zoho.com>
-# Contributor (Arch): Maxime Gauduin <alucryd@archlinux.org>
-# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-
-pkgname=light-locker-consolekit
-_pkgname=light-locker
-pkgver=1.6.0
-pkgrel=1.4
-pkgdesc='A simple session locker, with consolekit support'
-arch=('i686' 'x86_64' 'armv7h')
-url='https://github.com/the-cavalry/light-locker'
-license=('GPL2')
-depends=('dbus-glib' 'gtk3' 'libxxf86misc' 'lightdm' 'libxss' 'consolekit')
-makedepends=('gnome-common' 'intltool')
-conflicts=('light-locker' 'light-locker-upower')
-provides=('light-locker')
-install='light-locker.install'
-source=("https://github.com/the-cavalry/light-locker/releases/download/v${pkgver}/light-locker-${pkgver}.tar.bz2")
-sha256sums=('63e0cbcc7ceb8ad695b4bbe7eb9ba5fee32f47790ccde048748d8a47edd32ad0')
-
-build () {
- cd light-locker-${pkgver}
-
- ./configure \
- --prefix='/usr' \
- --localstatedir='/var' \
- --sysconfdir='/etc' \
- --with-x \
- --with-dpms-ext \
- --with-mit-ext \
- --with-xf86gamma-ext \
- --without-systemd \
- --with-console-kit \
- --without-upower \
- --disable-schemas-compile \
- --disable-static
- make
-}
-
-package() {
- cd light-locker-${pkgver}
-
- make DESTDIR="${pkgdir}" install
-}