summaryrefslogtreecommitdiff
path: root/pcr/libmypaint/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/libmypaint/PKGBUILD')
-rw-r--r--pcr/libmypaint/PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/pcr/libmypaint/PKGBUILD b/pcr/libmypaint/PKGBUILD
index 2ed94a495..f80d8d265 100644
--- a/pcr/libmypaint/PKGBUILD
+++ b/pcr/libmypaint/PKGBUILD
@@ -12,6 +12,11 @@ makedepends=(git gperftools scons) # fail build with gobject-introspection; docs
source=($pkgname::git+https://github.com/${pkgname#lib}/$pkgname)
sha512sums=(SKIP)
+pkgver() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd $srcdir/$pkgname
mkdir $srcdir/$pkgname-fakeinstall