summaryrefslogtreecommitdiff
path: root/pcr/laszip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/laszip/PKGBUILD')
-rw-r--r--pcr/laszip/PKGBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/pcr/laszip/PKGBUILD b/pcr/laszip/PKGBUILD
deleted file mode 100644
index 107966e3a..000000000
--- a/pcr/laszip/PKGBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor (Arch) : Maciej Sieczka <msieczka at sieczka dot org>
-# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
-
-pkgname='laszip'
-pkgver='2.2.0'
-pkgrel='1'
-pkgdesc='ASPRS LAS lossless compression library.'
-arch=('i686' 'x86_64')
-url='http://www.laszip.org'
-license=('LGPL2.1')
-provides=("$pkgname")
-source=("http://download.osgeo.org/laszip/laszip-src-2.2.0.tar.bz2")
-md5sums=('93194700623f6aca470454299361e89d')
-
-build() {
- cd "${srcdir}/laszip-src-2.2.0"
-
- msg 'Configuring build...'
- ./configure --prefix='/usr' --includedir="/usr/include/${pkgname}"
-# mkdir makefiles
-# cd makefiles/
-# cmake -D CMAKE_INSTALL_PREFIX="${pkgdir}/usr" -G 'Unix Makefiles' ../
-
- # To provide a usefull stacktrace:
- #
- # CFLAGS="-O0 -ggdb -Wall -Werror-implicit-function-declaration -fexceptions"
- # CXXFLAGS="-O0 -ggdb -Wall -Werror-implicit-function-declaration -fexceptions"
- # options=(!strip)
- # Not sure if -Werror-implicit-function-declaration -fexceptions should really go to CXXFLAGS.
- # Let me know if you know.
-
- msg 'Building...'
- make
-}
-
-package() {
- cd "${srcdir}/laszip-src-2.2.0"
- make DESTDIR="$pkgdir" install
-# cd "${srcdir}/${pkgname}-${pkgver}/makefiles"
-# make install
-}