summaryrefslogtreecommitdiff
path: root/pcr/jitsi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/jitsi/PKGBUILD')
-rw-r--r--pcr/jitsi/PKGBUILD70
1 files changed, 57 insertions, 13 deletions
diff --git a/pcr/jitsi/PKGBUILD b/pcr/jitsi/PKGBUILD
index 788d4f435..87913af64 100644
--- a/pcr/jitsi/PKGBUILD
+++ b/pcr/jitsi/PKGBUILD
@@ -1,34 +1,78 @@
# Maintainer: Xavier Devlamynck <magicrhesus@ouranos.be>
# Contributors: Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
+# Contributor (Parabola): Márcio Silva <coadde@lavabit.com>
pkgname=jitsi
-pkgver=2.0.4506.10553
-pkgrel=6
+pkgver=2.2.4603.9615
+pkgrel=2
pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'mips64el')
url="http://jitsi.org"
license=('LGPL')
-depends=('java-runtime')
-makedepends=('apache-ant' 'java-environment')
+depends=('jre7-openjdk')
+makedepends=('apache-ant' 'jdk7-openjdk')
options=(!strip !emptydirs zipman !libtool docs)
source=("http://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
jitsi.desktop
- jitsi.sh)
-sha256sums=('939adbda52b5aa19592bcd5edf5c77e1bcbbcaa4d0fcdb59c6b5c9e4a10b1e7d'
+ jitsi.sh
+ drop-open-term-on-index-jn-html.patch)
+sha256sums=('6ec46cc8f2306f5542c65fc637f70a7fe348b309ecc70a2483e05a745487ad41'
'61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d'
- '529722efc3bae6cb8923680363a4d778ccf78db9caf20bee90a110d34181d9f5')
+ '529722efc3bae6cb8923680363a4d778ccf78db9caf20bee90a110d34181d9f5'
+ 'a862465431e9d272e00bb9aafe56edec0d5c4f3718062add53972685adb90631')
+
+prepare() {
+ cd $srcdir/$pkgname-src-$pkgver
-build()
-{
- cd "${srcdir}/${pkgname}"
# append the build revision to the jitsi version
- sed -i "s/0\.build\.by\.SVN/build.${pkgver}/" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
+ sed -i "s|0.build.by.SVN|build.$pkgver|" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
+
+ # remove Open Source term
+ patch -Np0 -i ../drop-open-term-on-index-jn-html.patch
+ sed -i 's|Open Source / ||;
+ s|open source / ||;
+ s|Open Source|Free Software|;
+ s|open source|free software|;
+ ' $(grep -ril 'open source')
+ sed -i 's|OpenSource / ||;
+ s|opensource / ||;
+ s|OpenSource|FreeSoftware|;
+ s|opensource|freesoftware|;
+ ' $(grep -ril opensource)
+
+ # remove Linux term
+ sed -i '/, Linux/ s|Linux|GNU/Linux|;
+ /And Linux/ s|Linux|GNU/Linux|;
+ /and Linux/ s|Linux|GNU/Linux|;
+ /For Linux/ s|Linux|GNU/Linux|;
+ /for Linux/ s|Linux|GNU/Linux|;
+ /Linux,/ s|Linux|GNU/Linux|;
+ /Linux and/ s|Linux|GNU/Linux|;
+ /Linux distribution/ s|Linux|GNU/Linux|;
+ /Linux machine/ s|Linux|GNU/Linux|;
+ /Linux operating/ s|Linux|GNU/Linux|;
+ /Linux OS/ s|Linux|GNU/Linux|;
+ /Linux specific/ s|Linux|GNU/Linux|;
+ /Linux system/ s|Linux|GNU/Linux|;
+ /Under Linux/ s|Linux|GNU/Linux|;
+ /under Linux/ s|Linux|GNU/Linux|;
+ /On Linux/ s|Linux|GNU/Linux|;
+ /on Linux/ s|Linux|GNU/Linux|;
+ s|GNU/GNU|GNU|;
+ s|GNU/Linux kernel|Linux kernel|;
+ s|GNU/Linux specific kernel|Linux specific kernel|;
+ ' $(grep -rl Linux)
+}
+
+build() {
+ cd $srcdir/$pkgname-src-$pkgver
. /etc/profile.d/apache-ant.sh
ant rebuild
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd $srcdir/$pkgname-src-$pkgver
find lib/ lib/bundle/ -maxdepth 1 -type f \
-exec install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/"{} \;
find lib/os-specific/linux/ -maxdepth 1 -type f \