summaryrefslogtreecommitdiff
path: root/pcr/guile-ssh/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/guile-ssh/PKGBUILD')
-rw-r--r--pcr/guile-ssh/PKGBUILD39
1 files changed, 31 insertions, 8 deletions
diff --git a/pcr/guile-ssh/PKGBUILD b/pcr/guile-ssh/PKGBUILD
index b837a76c8..06c09d4a6 100644
--- a/pcr/guile-ssh/PKGBUILD
+++ b/pcr/guile-ssh/PKGBUILD
@@ -4,8 +4,9 @@
# no changes.
pkgname=guile-ssh
-pkgver=0.11.2
-pkgrel=2
+pkgver=0.11.3
+pkgrel=5
+pkgrel+=.par1
pkgdesc='SSH module for Guile based on libssh'
arch=('x86_64' 'i686' 'armv7h')
url="https://github.com/artyom-poptsov/guile-ssh"
@@ -13,22 +14,44 @@ license=('GPL3')
depends=(
'guile>=2.0.9'
'libssh>=0.7.3')
-source=("https://github.com/artyom-poptsov/guile-ssh/archive/v${pkgver}.tar.gz")
-sha256sums=('20e9109fe5dd21c9294a94cba12b65cc7650f359e52e7a16f3bdc89e802e13f0')
+source=(
+ "https://github.com/artyom-poptsov/guile-ssh/archive/v${pkgver}.tar.gz"
+ 'guile-ssh-0.11.3-fix-segfault.patch'
+ 'guile-ssh-0.11.3-libssh-0.8-name.patch'
+ 'guile-ssh-0.11.3-libssh-0.8-tests.patch'
+ 'guile-ssh-0.11.3-libssh-0.9-ecdsa.patch')
+sha256sums=(
+ '1373bf6f30ba9b4404c044fb00c0509cbd851606264803faccbf881b1efb52bc'
+ 'f3284d61b7166be9809e37c7ced323d45255479e51f68f46f0499d9a3056b535'
+ '4a0ab224a08afc832ce82dc055f23c36c56f7e63f4f2b1814571a3c930d9cae6'
+ '5594153165cade97481c50284aade32153801232c65a958abd3e25a2eb237841'
+ 'df4d3955601bc540df02c4418bc4b36b15971077c3162e328b9dfa989bc0b84b')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ local source_file
+ for source_file in "${source[@]}"; do
+ case "${source_file}" in
+ *.patch)
+ patch -p1 < "${srcdir}/${source_file}"
+ ;;
+ esac
+ done
+}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
autoreconf -fi
./configure --prefix=/usr --disable-rpath
make
}
check() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make check || true # tests unexpectedly fail
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}