summaryrefslogtreecommitdiff
path: root/pcr/fwsnort/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/fwsnort/PKGBUILD')
-rw-r--r--pcr/fwsnort/PKGBUILD54
1 files changed, 27 insertions, 27 deletions
diff --git a/pcr/fwsnort/PKGBUILD b/pcr/fwsnort/PKGBUILD
index 0f470ca37..b4983658d 100644
--- a/pcr/fwsnort/PKGBUILD
+++ b/pcr/fwsnort/PKGBUILD
@@ -1,44 +1,44 @@
-# Contributor (Arch): Colin Shea <colin@evaryont.me>
-# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+# Contributor: Colin Shea <colin@evaryont.me>
+# Maintainer : Parabola GNU / Linux-libre Aurélien DESBRIÈRES <aurelien@hackers.camp>
pkgname=fwsnort
-pkgver=1.6.2
-pkgrel=1
+pkgver=1.6.3
+pkgrel=3
pkgdesc="application layer IDS/IPS by translating snort rules into iptables"
arch=('any')
url="http://www.cipherdyne.org/fwsnort/"
license=('GPL')
-depends=('perl' 'perl-net-ipv4addr' 'perl-iptables-parse' 'iptables' 'net-tools')
+# net-tools: sorry, but fwsnort needs ifconfig. Doesn't support iproute yet
+depends=('perl' 'perl-netaddr-ip' 'perl-iptables-parse' 'iptables' 'net-tools')
makedepends=('wget')
source=(http://www.cipherdyne.org/$pkgname/download/$pkgname-$pkgver.tar.bz2
'install_pl.patch')
+options=(emptydirs)
+
build() {
cd "$srcdir/$pkgname-$pkgver"
- mkdir -p $pkgdir/var/log/fwsnort \
- $pkgdir/usr/lib/fwsnort \
- $pkgdir/usr/share/man/man8 \
- $pkgdir/usr/sbin \
- $pkgdir/etc/fwsnort/snort_rules \
- $pkgdir/etc/fwsnort/archive \
- $pkgdir/etc/fwsnort/snort_rules_queue
-
- patch -p0 -i $srcdir/install_pl.patch
- sed -e "/mpath.*man8/s|/usr|$pkgdir&|" \
- -e "/^my\\ \\\$sbin/s|/usr|$pkgdir&|" \
- -i install.pl
-
- cp fwsnort.conf fwsnort.conf.bak
-
- sed -e "s|/var/log/fwsnort|$pkgdir&|" \
- -e "s|/usr/lib/fwsnort|$pkgdir&|" \
- -e "s|/etc/fwsnort|$pkgdir&|" \
- ./fwsnort.conf -i
+ # fix up the installer for our purposes:
+ # - removes the root check
+ # - includes sbin as another place to check for binares
+ # - fixes various paths for utilities & the man page
+ patch -p1 -i $srcdir/install_pl.patch
+
# -S skips installing the perl modules, which we did with packages
- echo y | ./install.pl -S
- mv -f fwsnort.conf.bak $pkgdir/etc/fwsnort/fwsnort.conf
- chmod 755 $pkgdir/usr/sbin/fwsnort
+ # and --install-test-dir sets the INSTALL_ROOT to src/../test/fwsnort-test. An
+ # easy way to collect all the files into 1
+ ./install.pl -S --install-test-dir
+}
+
+package() {
+ cp -r $srcdir/fwsnort-$pkgver/test/fwsnort-install/* -t $pkgdir
+ # delete references to $pkgdir from fwsnort; they were made by the installer
+ # as part of installing to the test dir
+ cp -f $srcdir/fwsnort-$pkgver/fwsnort.conf $pkgdir/etc/fwsnort/fwsnort.conf
+
+ # avoid a 'warning: directory permissions differ on etc/' line from pacman
+ chmod 755 $pkgdir/etc
}
# vim:set ts=2 sw=2 et: