summaryrefslogtreecommitdiff
path: root/pcr/connman-ui-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/connman-ui-git/PKGBUILD')
-rw-r--r--pcr/connman-ui-git/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/pcr/connman-ui-git/PKGBUILD b/pcr/connman-ui-git/PKGBUILD
index e9296fa76..79148b563 100644
--- a/pcr/connman-ui-git/PKGBUILD
+++ b/pcr/connman-ui-git/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: freaj <freaj@riseup.net>
-# Maintainer (Arch) Bertrand Bonnefoy-Claudet <bertrandbc@gmail.com>
+# Maintainer (Arch): Bertrand Bonnefoy-Claudet <bertrandbc@gmail.com>
+# Contributor (Arch): Timothy Lee <timothy.ty.lee@gmail.com>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=connman-ui-git
-pkgver=r25.b0a09f9
+pkgver=r38.fce0af9
pkgrel=1
pkgdesc="A full-featured GTK based trayicon UI for ConnMan (git version)"
arch=('i686' 'x86_64')
@@ -10,8 +11,10 @@ url="https://github.com/tbursztyka/connman-ui"
license=('GPL2')
depends=('connman' 'gtk3')
makedepends=('git' 'intltool')
-source=("git+https://github.com/tbursztyka/connman-ui.git")
-md5sums=('SKIP')
+source=('git+https://github.com/tbursztyka/connman-ui.git'
+ 'connman-ui-autostart.desktop')
+sha256sums=('SKIP'
+ 'b249cd6d59cb8814ff1d9445efe1bdbc99d164daebe0f693dda938874736a3f8')
_gitroot="connman-ui"
@@ -30,5 +33,8 @@ build() {
package() {
cd "$srcdir/$_gitroot"
make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -D -m 644 "$startdir/connman-ui-autostart.desktop" \
+ "$pkgdir/etc/xdg/autostart/connman-ui-autostart.desktop"
+ install -D -m 644 "$pkgdir/usr/share/connman_ui_gtk/icons/gsm-3g-full.png" \
+ "$pkgdir/usr/share/icons/hicolor/64x64/apps/connman-ui.png"
}
-