summaryrefslogtreecommitdiff
path: root/nonsystemd/libretools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/libretools/PKGBUILD')
-rw-r--r--nonsystemd/libretools/PKGBUILD132
1 files changed, 42 insertions, 90 deletions
diff --git a/nonsystemd/libretools/PKGBUILD b/nonsystemd/libretools/PKGBUILD
index 6b2c2664a..d8e630751 100644
--- a/nonsystemd/libretools/PKGBUILD
+++ b/nonsystemd/libretools/PKGBUILD
@@ -1,27 +1,41 @@
-# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
# Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: Márcio Silva <coadde@hyperbola.info>
-pkgbase=libretools
-pkgname=(libretools librelib gitget)
-pkgdesc="Programs for Parabola development"
-url="https://git.parabola.nu/packages/libretools.git/"
-license=('GPL3' 'GPL2')
-
+pkgname=libretools
pkgver=20181004
-source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
- Remove-systemd-support.patch
- 0002-libremakepkg-pacman_5_2.patch)
-sha256sums=('2bdefd1803ba3e6cbd1eb955fad3de9ce8a4abfd23a0bd96a60772762df7b53b'
- 'SKIP'
- '4257e7c5383df8c322d79f8e601893f71eeccbd1b9ceac76c8ebbc90fb609875'
- '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
-validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
-
pkgrel=6.1
pkgrel+=.nonsystemd2
+pkgdesc="Programs for Parabola development"
arch=('any')
+url="https://git.parabola.nu/packages/libretools.git/"
+license=('GPL3' 'GPL2')
+backup=(etc/libretools.conf
+ etc/libretools.d/chroot.conf
+ etc/libretools.d/libredbdiff.conf
+ etc/libretools.d/librefetch.conf)
+install=libretools.install
+conflicts=(devtools libretools-mips64el)
+replaces=(libretools-mips64el)
+depends=(
+ "librelib=$pkgver"
+ "gitget=$pkgver" # `createworkdir`
+ 'pacman>=5.1.1-1.parabola5' 'pacman<5.3'
+ arch-install-scripts # `mkarchroot` uses `pacstrap`
+ binutils # `libremakepkg` uses `makepkg` uses `strip`
+ expac # `libredbdiff`
+ fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
+ make # `librefetch`
+ openssh # `librerelease`
+ rsync # `librerelease` and `makechrootpkg.sh`
+ chroot-nspawn # chroot-nspawn
+ tokyocabinet # `toru`
+ #namcap # Namcap is currently dissabled in libremakepkg :-(
+ subversion # `diff-unfree`
+ wget # `aur`, optdepend for librelib:`blacklist`
+)
+optdepends=('qemu-user-static-binfmt: To build ARM packages from x86')
makedepends=(ruby-ronn)
checkdepends=(
bash-bats git
@@ -31,17 +45,25 @@ checkdepends=(
rsync
tokyocabinet
)
+source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
+ nonsystemd.patch
+ 0002-libremakepkg-pacman_5_2.patch)
+sha256sums=('2bdefd1803ba3e6cbd1eb955fad3de9ce8a4abfd23a0bd96a60772762df7b53b'
+ 'SKIP'
+ '511de3404afcb3fe2ed002a94be00bc0b83d6abeb1cf3ab0456bf916c8f1114e'
+ '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
+validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
prepare() {
cd "$srcdir/$pkgbase-$pkgver"
# non-systemd patch changes:
# * uses chroot-nspawn instead of systemd-nspawn
- # * removes the usage of unnecessary systemd utilities
- patch -p1 -i ../Remove-systemd-support.patch
+ # * replaces systemd-machine-id-setup with dbus-uuidgen
+ patch -p1 -i ../nonsystemd.patch
# don't apply 0001-libremakepkg-rw-startdir.patch like libre/libretools because
- # non-systemd systems don't have that issue
+ # by using chroot-nspawn we don't have that issue
patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
}
@@ -50,77 +72,7 @@ build() {
make
}
-check() {
- cd "$srcdir/$pkgbase-$pkgver"
- # FIXME as soon as possible
- # we needed to unbreak kernel builds, but tests were failing
- # with the stock PKGBUILD like this:
- # | not ok 13 libreblacklist works with everything set
- # | # (in test file cases/lib-blacklist.bats, line 15)
- # | # `v="$(libreblacklist get-rep <<<"$line")"; [[ $v == 'libre/linux-libre' ]]' failed
- # | # gpg: Warning: using insecure memory!
- # | # gpg: key 57169AAE979EC3AB marked as ultimately trusted
- # | # gpg: Warning: using insecure memory!
- # | # OK closing connection
- # SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
-}
-
-package_librelib() {
- pkgdesc="The shell library portion of libretools"
- license=(GPL2)
- conflicts=('xbs')
- optdepends=(
- 'libretools: for libreblacklist/blacklist.sh'
- 'wget: for libreblacklist/blacklist.sh'
- )
-
- cd "$srcdir/$pkgbase-$pkgver"
- make install-librelib DESTDIR="$pkgdir"
-}
-
-package_gitget() {
- pkgdesc="A simple to use downloader for git URLs"
- license=(GPL2)
- depends=("librelib=$pkgver" git)
-
- provides=("libregit=$pkgver")
- conflicts=("libregit")
- replaces=("libregit")
-
- cd "$srcdir/$pkgbase-$pkgver"
- make install-gitget DESTDIR="$pkgdir"
-}
-
-package_libretools() {
- backup=(etc/libretools.conf
- etc/libretools.d/chroot.conf
- etc/libretools.d/libredbdiff.conf
- etc/libretools.d/librefetch.conf)
- install=libretools.install
- conflicts=(devtools libretools-mips64el)
- replaces=(libretools-mips64el)
-
- depends=(
- "librelib=$pkgver"
- "gitget=$pkgver" # `createworkdir`
- 'pacman>=5.1.1-1.parabola5' 'pacman<5.3'
- arch-install-scripts # `mkarchroot` uses `pacstrap`
- binutils # `libremakepkg` uses `makepkg` uses `strip`
- expac # `libredbdiff`
- fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
- make # `librefetch`
- openssh # `librerelease`
- rsync # `librerelease` and `makechrootpkg.sh`
- chroot-nspawn # chroot-nspawn
- tokyocabinet # `toru`
- #namcap # Namcap is currently dissabled in libremakepkg :-(
- subversion # `diff-unfree`
- wget # `aur`, optdepend for librelib:`blacklist`
- )
- optdepends=(
- 'qemu-user-static-binfmt: To build ARM packages from x86'
- )
-
+package() {
cd "$srcdir/$pkgbase-$pkgver"
make install-libretools DESTDIR="$pkgdir"
}