summaryrefslogtreecommitdiff
path: root/nonprism/webkit2gtk/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/webkit2gtk/PKGBUILD')
-rw-r--r--nonprism/webkit2gtk/PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/nonprism/webkit2gtk/PKGBUILD b/nonprism/webkit2gtk/PKGBUILD
index 3c76c199a..0b26b3777 100644
--- a/nonprism/webkit2gtk/PKGBUILD
+++ b/nonprism/webkit2gtk/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=webkit2gtk
pkgver=2.18.3
-pkgrel=3.nonprism1
+pkgrel=3.nonprism2
arch=(i686 x86_64 armv7h)
pkgdesc="GTK+ Web content engine library, without geoclue2 support"
@@ -38,11 +38,12 @@ prepare() {
build() {
cd build
+ # temporarily disabling GTKDOC build, it breaks compilation on x86_64
cmake -G Ninja -DPORT=GTK -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=/usr/lib -DLIBEXEC_INSTALL_DIR=/usr/lib/webkit2gtk-4.0 \
-DUSE_GEOCLUE2=OFF -DENABLE_GEOLOCATION=OFF \
- -DENABLE_GTKDOC=ON -DPYTHON_EXECUTABLE=/usr/bin/python2 ../webkitgtk-$pkgver
+ -DENABLE_GTKDOC=OFF -DPYTHON_EXECUTABLE=/usr/bin/python2 ../webkitgtk-$pkgver
if [[ "$CARCH" =~ ^arm*|^aarch64$ ]]; then
# strip -O3 from cmake generated makefiles