summaryrefslogtreecommitdiff
path: root/nonprism/gthumb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/gthumb/PKGBUILD')
-rw-r--r--nonprism/gthumb/PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/nonprism/gthumb/PKGBUILD b/nonprism/gthumb/PKGBUILD
index 8ff63015d..152be0486 100644
--- a/nonprism/gthumb/PKGBUILD
+++ b/nonprism/gthumb/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 224110 2014-10-08 18:16:28Z heftig $
+# $Id: PKGBUILD 236546 2015-04-14 17:41:47Z heftig $
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
# Contributor (Arch): Tobias Kieslich <tobias@justdreams.de>
@@ -6,8 +6,8 @@
# Contributor: Márcio Silva <coadde@parabola.nu>
pkgname=gthumb
-pkgver=3.2.8
-pkgrel=2.nonprism1
+pkgver=3.4.0
+pkgrel=1.nonprism1
pkgdesc="Image browser and viewer for the GNOME Desktop, without support for unsafe and dangerous for privacy protocols"
arch=(i686 x86_64)
license=(GPL)
@@ -17,9 +17,9 @@ conflicts=(${pkgname}-nonprism)
depends=(desktop-file-utils hicolor-icon-theme dconf librsvg clutter-gtk
gst-plugins-base-libs gsettings-desktop-schemas libwebp libsecret
libsoup webkit2gtk json-glib)
-makedepends=(intltool libchamplain libopenraw exiv2 itstool brasero librsvg
- libopenraw liboauth docbook-xsl yelp-tools gnome-common)
-optdepends=('libopenraw: read RAW files'
+makedepends=(intltool libchamplain exiv2 itstool brasero libraw liboauth
+ docbook-xsl yelp-tools gnome-common flex)
+optdepends=('libraw: read RAW files'
'exiv2: metadata support'
'libchamplain: map viewer'
'brasero: burn discs'
@@ -27,17 +27,13 @@ optdepends=('libopenraw: read RAW files'
options=('!emptydirs')
install=gthumb.install
source=(http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
- webkit2gtk-4.0.patch
nonprism.patch)
-sha256sums=('d600aba747af551540f3bbae8e8afa1cc308c658d911318c98fd4bf52ecd61b8'
- '0174bdff5d193962d52cb018f233570b8f18a740281f51b79bc52f18c4e9a929'
- '7706181514c9cfe0241329e9b14778dfa2797ddc1feb206b1cd9f07f9be31490')
+sha256sums=('abd1afe457c65289af31c6db7037452faa3838356480857d8cdc19f0ecde4933'
+ 'b1cd2463ab6475ce91a2b2e83dfcb1835ffaa9640c59d7bcfbe611163327fa45')
prepare() {
cd $pkgname-$pkgver
- patch -Np1 -i ../webkit2gtk-4.0.patch
patch -Np1 -i ../nonprism.patch
- AUTOPOINT='intltoolize --automake --copy' autoreconf -fi
}
build() {
@@ -45,7 +41,7 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --disable-static \
- --enable-libchamplain --enable-libopenraw
+ --enable-libchamplain
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool